open MPI mpirun error

open MPI mpirun error

dear all,

this is my problem:

when I try to run the mpirun I get the following error:

/opt/intel/composer_xe_2013.5.192/mpirt/bin/intel64/mpirun: 96: .: Can't open /opt/intel/composer_xe_2013.5.192/mpirt/bin/intel64/mpivars.sh

I do not have intel MPI, this means that is not a problem between the MPI and openMPI.

Thanks a lot to everyone

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I believe this is an FAQ on OpenMPI.  You must assure that your intended OpenMPI installation comes first on PATH and LD_LIBRARY_PATH, ahead of the ifort co-array support which is placed there by sourcing the compilervars script.  So you must set up OpenMPI paths after setting up ifort paths, or modify the compilervars to look for presence of OpenMPI just as it does for Intel MPI.

Dear Tim P.,

Let's me see if I have understood corectly:

For the intel fortran I have this rows in my bash:

source /opt/intel/bin/compilervars.sh intel64
source /opt/intel/mkl/bin/mklvars.sh intel64 mod lp64
export PATH

Do you mean that I have to do something like that for my mpirun?

am I right?

How can I do?

I am sorrym but I do not know very well bash environment

Thanks a lot

Yes, after setting the ifort  paths, you would prepend the paths for your OpenMPI, e.g.

export PATH=/opt/ompi-1.6/bin:$PATH

export LD_LIBRARY_PATH=/opt/omp-1.6/lib64:$LD_LIBRARY_PATH

according to where your OpenMPI is installed. 

Then, for example,

"which mpirun"

should pick up the one from your OpenMPI.

That OpenMPI would have been installed with its mpif library built by ifort (not the one which comes with a linux distro), so you probably need to talk with your sysadmin (even if that's you).

Dear Tim,

thanks a lot.

Now it's seem working. When I installed openMPI and I configure it I used the following comand:

 ./configure --prefix=/opt/openmpi cc=icc cxx=icpc f77=ifort fc=ifort

This mean that I should pick-up the correct compiler.

Is this ok? Is this that you mean in the last two rows?

again thanks a lot, I am learning a lot. Now It's clear why I used that ./configure....

another question about MPI world:

when I run a simulation with

mpirun - np "number of processors" *.out

It seems that it works even if I use a number of processors greater that which I actually have. Is this correct? Or does this mean that I have an installation problem?

Thanks again

 

Apparently, you followed their instructions to set up with ifort, which should take care of that, as long as you have /opt/openmpi/bin ahead of ifort on PATH, and /opt/openmpi/lib64 ahead of ifort on LD_LIBRARY_PATH.

In past versions, OpenMPI had no default CPU pinning, and was happy running 2 or more processes per core.  For best result on a dual CPU platform, when not over-subscribed, you would set the pinning options.  With the latest versions, as with Intel MPI, you would need to turn off the pinning explicitly for satisfactory over-subscription (if there is default pinning on your platform).

Login to leave a comment.