My desktop has a SEIKI 39" 4K TV/Monitor attached via HDMI. I do not use this for games, just for gobs of desktop (e.g. so I can eliminate additional monitors). On the desktop it works great, except for an occasional 4-5 second black screen. Others have this problem, and this is background for my question below.

I wanted to see  if Intel Software Development Platform Ultrabook HDMI could drive this Monitor (TV). The screen is recognized (Mfg. Name, model number, resolution, refresh rate). However, upon selecting the correct properties, the display momentarily displays nicely, but then shortly, the image gets skewed. It looks as if the horizontal sync (width) blanking interval is wrong. The vertical blanking interval may be wrong too, but I cannot tell.

Is this a known problem?

If not, is there a tweak program available that I can use to create a different profile. (One that works with the Intel integrated graphics controller inside the Haswell CPU of the UB).

Jim Dempsey

30 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

By the way, Remote Desktop to the system with the 4K monitor is great. Text is tiny, but all is clear.

Jim Dempsey

Hi Jim,

HDMI doesn't have Horizontal and Vertical syncs like Analogue signals.  The port must be HDMI 1.4 or above to drive 4k screen as this requires a fast data rate.  It sounds like you are on the edge of the digital cliff so try a different HDMI cable ideally as short a cable as you can.

Hope this helps,


I am aware that HDMI is digital.

The symptoms appear as if the horizontal sync is wacked. Saw tooth pattern on left and right margins, image tilted in each saw tooth. That pattern appears scroll (roll) as if vertical sync wacked too. Note use of "appears to".

This indicates that each line is skewed by a few pixels. Apparently there is a disparity between the number of line pixels to be sent and the number of line pixels assumed to be received (thus inducing the skew).


Hi Jim,

The eye diagram will be virtually closed and the odd error will mean pixels may be incorrect or the addressing of the pixels will be incorrect - hence the skewed bits of image.

As I said, try a different cable - shorter the better as a test.


The one I have is 8'. I do not think I saw a shorter one at Best Buy. Can look on line. The 8' was over $40 (with the micro HDMI connector). I see a 6' on Newegg for ~$6. Anything shorter than that makes it somewhat non-functional.

At the last IDF, they were running 6' to 8' no problems.

Is that an older Land Rover?

Jim Dempsey

Hey Jim - does it work at lower resolutions? I'd also try lowering the refresh rate just to see if you can get it working/stable.

And then I agree w David, try getting a high quality HDMI 1.4 or 2.0 cable. 

It "should" work ;)  And nice TV btw





Hi Jim,

Yep, it's a Series III 88inch Land Rover 30 years old this year.


I tried 25Hz same problem. I did not try lower resolution. No point in that. I know 1080P works (on HD monitor/TV) but then I would have a large grainy screen of little use. The desired effect is more content, not larger screen size.

By the way, the 13" screen on the Lenovo Yoga 2 Pro Ultrabook is superb at 3200x1800 resolution. This near the 3840x2160 that I get on the Seiki. A 17" screen would be even nicer, though the heft would be more. With my older notebook I would haul along an additional 24" HD LED screen when doing off-site programming. Lenovo should think about offering a 13" 3200x1800 companion screen (as well as 15" and 17"). IOW same size and resolution as on notebook. This all could fit nicely in the notebook carrying case.

I will try an HDMI 2 cable. Though they should be the same, it is possible that the HDMI 2 "certified"? cable might exhibit less signal skew amongst the conductors. My principal interest is not for daily use, rather for use at a small group presentation (e.g. trade show booth).

Jim Dempsey

Oh nice ... I've been eyeing that Yoga 2.  It'll either be that or the qhd HP Envy 14 - but Lenovo just seems to be getting it right these days.

I mentioned lowering the res just as a test case - if it works at 1080p it might just the cable.  If not then drivers, etc - but I'm guessing you don't need advice on troubleshooting ....  ;)

Cables in my experience have always been funny. I've had cables that work great with some hardware and then not all with others - at the same resolution.  But I've never seen the issue you're describing - it's usually either all of nothing, and once I had long cable causing random "snow".

To the best of my knowledge a 2.0 cable shouldn't be better than 1.4 cable for handling bandwidth.  Any high speed cable "should" work, And I don't think the certification branding means anything.

If another cable doesn't do it I'd be looking to put the blame on the Ultrabook itself - I'm assuming the Intel dev platforms just don't go through the same level of testing as retail machines (I seem to recall seeing some hand soldered leads in my Ivy Bridge ref platform).  But of course I'm only guessing.






Hey Jim,

I've been watching this thread for a couple of weeks because I also have the Seiki 39" 4k and Yoga Pro 2 combination for my development workstationo. My HP desktop seems to drive the monitor without any issues (it has the same Haswell/Intel HD Graphics 4400 combo with regular HDMI) but I get the "No Support" message when I attempt to get 3840x2160/4k resolution using the Yoga's Micro-HDMI.

Please let me know if you've been able to resolve this with the micro-HDMI cable upgrade,


With your HP desktop, does your Seiki go black every few minutes? Mine does, it comes back on in a few seconds. It is a bit annoying. Having 4x the content is more of a benefit than the inconvenient of a momentary blackout.

My monitor firmware: Baseline Ver: 179, Customer Ver 1.1, Produce Date: Aug 26 2013

The production date appears to be on the order of the latest firmware date from the Seiki website (20130827), so I haven't re-flashed. I suppose I could re-flash.

I haven't measured, but I seem to recall I am using an 8' HDMI "high performance" cable on the desktop.

The cable I have for the Ultrabook is an 8' Rocketfish. I was thinking of trying a 3', though that would be tight. I am hesitant to layout $40 for a non-solution.

I have a Bluetooth mouse, I suppose I could add a Bluetooth keyboard then configure the Ultrabook as a tablet and lay it under the screen.

It is interesting to note in your case that the "display adapters" are essentially the same (HD Graphics 4400). You do have a different cable as the desktop likely does not have a micro-HDMI port. Maybe it is a cable thing.

Another option might be something like an active HDMI switch: http://www.monoprice.com/Product?seq=1&format=2&p_id=8462&CAWELAID=1329456935&CAGPSPN=pla&catargetid=320013720000010715&cadevice=c&cagpspn=pla&gclid=CP3A3eOUsL0CFfFFMgodPUwA7Q

The switch also incorporates an amplifier, which automatically regenerates the HDMI signal to full strength, allowing you to use longer-than-normal HDMI cables from the input devices. An external 5VDC power supply is required and supplied with the unit.

If I stumble upon a solution, I will post it back here.

Jim Dempsey


Sorry for off-topic question.

I just received Lenovo Yoga 2 ultrabook and seems that I have a problem with the Internet browsing.Failed DNS resolution can be blamed for that.

Now I wanted to ask you did you have the same kind of problems with your ultrabook?

Thanks in advance.


Please disregard my question because I have solved the issue.

Hi Iliyapolak,

I always try to include the fix in a post as although the fix might be trivial I believe that if someone felt the need to post a question it implies their problem was causing them a big enough of an issue to make them want to post.  If it was causing them an issue then a similar problem might cause other less savvy people even more of a problem.

Aside from that I was curious.  Was it your ISP or the network adaptor settings for the DNS?  If I get DNS issues one of the first things I do is to use a Google DNS - and this usually works so I can then figure out where the problem actually lies.



Sorry for late answer.

Yes I did what you mentioned in your post,but really  nothing was helpful.It was strange because my main laptop and Asus tablet were connected to the same network and were able to access Internet without any problem.

I installed wireshark on the Yoga and started to monitor  websites connections attempts.DNS servers IP's were provided by the ISP and unfortunately very quickly I saw those pesky messages talking about the DNS failed query.At this moment I started to suspect McAffee AV and firewall to be a main culprit of behind the failed DNS resolution.I theorized that probably filter driver installed by McAffee firewall  which is probably sitting above 802.11 driver and below TCP/IP driver and is blocking network traffic.The second suspect was winsock and probably some kind of hooks installed by AV.One of very popular target of hooking could be GetHostByName function.I thought about trying to check the image with the windbg for consistency,but decided to try a very simple workaround.My external usb wi-fi card Alpha was connected and everything started to work fine.

I would disable firewall & AV and retry.  Is the McAfee a trial version?

If the McAfee is doing it by design (and I don't know why it should) then defeating it by adding an additional Network Adaptor seems a flaw in the AV/Firewall policy.   

Personally I dislike preinstalled trial versions.



I did  exactly what you advised me and still was not able to browse the websites.I even uninstalled trial version of McAffee and still DNS resolution was not working.So probably it was not AV or firewall.

I suspect that probably pre- installed version of Win 8.1 could be blamed for DNS issues.

My next thought would be to go to the network adaptors page and look at what is there.  If you have Hyper-V Virtual Ethernet adaptors it could be they are not configured correctly or browsing is routed via them.

I presume it is purely DNS so if you browse to you should get to a well known search engine.

Then I would go to the Yoga WiFi adaptor, disable it and then enable it.

Maybe that would help.


I do not have enabled Hyper-V.I monitored network traffic via netmon and registered interfaces are built-in Intel wlan card and Alpha wlan card.

Regarding Yoga built-in card I disabled and enabled it and it was not helpful so far.Now I am considering to reinstall the driver maybe this will solve the issue.

With just the internal WiFi did you try to browse

Do you have any proxy setup on that I/F?

Does ping google.com from command prompt work?

How about ping

What does ipconfig /all give you?

Reinstalling driver might well clear the issue but it sounds like a configuration issue.  Did Lenovo have any comment?


>>>With just the internal WiFi did you try to browse>>>

It was not successful , DNS resolution failed.

>>>Do you have any proxy setup on that I/F?>>>

No I do not have any proxy.Double checked that.

>>>Does ping google.com from command prompt work?

How about ping>>>

No everything is blocked.There is no response from the remote server.I tried this when Mc Affee was uninstalled.

>>>What does ipconfig /all give you?>>>

It gives properly configured network with DHCP assigned client IP address.

I started to run out of ideas.I do not want to dig deep into networking stack internals.My knowledge is scarce and serious troubleshooting of NIDS driver is supported only in checked build Windows.

Now I am using external card with good results.

if you cannot use a browser to go to or ping then it is not DNS error.  It appears all traffic is failing to get through.  This sounds like a firewall, adaptor configuration or driver issue.

It is worth checking your gateway address is correct.

From command prompt try tracert as this may give you a clue as to where it is failing.


Also can you successfully ping/browse to anything on your local network?


>>>It is worth checking your gateway address is correct.

From command prompt try tracert as this may give you a clue as to where it is failing>>>

Actually pinging default gateway also fails so this is issue is probably related to networking stack drivers.I suspect *IRP's beign not received by underlying wlan driver, but it is hard to troubleshoot it properly.I am thinking about the generating full kernel dump with NotMyFault tool and trying to find outstanding IRP's

*IRP = I/O Request Packet.


>>>Also can you successfully ping/browse to anything on your local network?>>>

Unfortunately no.

So the DHCP server is giving the internal wlan adaptor the address, subnet and gateway address and you have double checked they are correct.

When you browse do you get an 'identify problem' or 'troubleshooter' button and if so what happened when you clicked it?


>>>So the DHCP server is giving the internal wlan adaptor the address, subnet and gateway address and you have double checked they are correct>>>

Yes of course.

Also PHY (physical layer) is working fine.The problem could be related to the higher level protocols(TCP/IP stack).

>>>When you browse do you get an 'identify problem' or 'troubleshooter' button and if so what happened when you clicked it>>

I clicked automatic troubleshooting button, but without the any help.

I presume you have raised the issue with Lenovo.

Have you tried a completely different WiFi network?

Just trying to think what else could cause the issues you have reported.


Unfortunately all other Wi-Fi networks in the range are protected.Today I plan to reinstall the driver and hope that this will solve the problem.

I still did not contact Lenovo.

Unfortunately driver reinstallation did not help.I will force machine into BSOD and try to debug NDIS.

Leave a Comment

Please sign in to add a comment. Not a member? Join today