Getting 1440x900 with a 82915G card on a Samsung 2243 issues

Getting 1440x900 with a 82915G card on a Samsung 2243 issues

Ok, I have sene many articles about this and it looked like editing the .inf install file was the way to go according to this article. I went through the article, verified I had the right DTD and even went through the registry and manually entered it but it still will not show up.

I tried downloading the Powerstrip demo and after adding the custom resolution of 1440x900, it displayed but made me have to scroll around (ie: it spilled over the edges of the monitor making it too big).

So I am back to edit the INF file but am not sure what else to do. Here is the output from MonInfo:

Monitor
Model name............... SyncMaster
Manufacturer............. Samsung
Plug and Play ID......... SAM0581
Serial number............ H9NS806441
Manufacture date......... 2009, ISO week 35
-------------------------
EDID revision............ 1.3
Input signal type........ Analog 0.700,0.300 (1.0V p-p)
Sync input support....... Separate, Composite, Sync-on-green
Display type............. RGB color
Screen size.............. 480 x 270 mm (21.7 in)
Power management......... Active off/sleep
Extension blocs.......... None
-------------------------
DDC/CI................... Supported
MCCS revison............. 2.0
Display technology....... TFT
Controller............... Mstar 0x1000
Firmware revision........ 0.1
Firmware flags........... 0x00000001
Active power on time..... Not supported
Power consumption........ Not supported
Current frequency........ Not supported

Color characteristics
Default color space...... Non-sRGB
Display gamma............ 2.20
Red chromaticity......... Rx 0.649 - Ry 0.335
Green chromaticity....... Gx 0.283 - Gy 0.605
Blue chromaticity........ Bx 0.151 - By 0.073
White point (default).... Wx 0.313 - Wy 0.329
Additional descriptors... None

Timing characteristics
Horizontal scan range.... 30-75kHz
Vertical scan range...... 56-61Hz
Video bandwidth.......... 170MHz
CVT standard............. Not supported
GTF standard............. Not supported
Additional descriptors... None
Preferred timing......... Yes
Native/preferred timing.. 1920x1080p at 60Hz (16:9)
Modeline............... "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

Standard timings supported
640 x 480p at 60Hz - IBM VGA
800 x 600p at 56Hz - VESA
800 x 600p at 60Hz - VESA
1024 x 768p at 60Hz - VESA
1280 x 800p at 60Hz - VESA STD
1280 x 960p at 60Hz - VESA STD
1280 x 1024p at 60Hz - VESA STD
1440 x 900p at 60Hz - VESA STD
1680 x 1050p at 60Hz - VESA STD
1600 x 1200p at 60Hz - VESA STD

Report information
Date generated........... 12/28/2009
Software revision........ 2.43.0.822
Operating system......... 5.1.2600.2.Service Pack 3

Raw data
00,FF,FF,FF,FF,FF,FF,00,4C,2D,81,05,32,32,59,4D,23,13,01,03,0E,30,1B,78,2A,78,F1,A6,55,48,9B,26,
12,50,54,23,08,00,81,00,81,40,81,80,95,00,B3,00,A9,40,01,01,01,01,02,3A,80,18,71,38,2D,40,58,2C,
45,00,DD,0C,11,00,00,1E,00,00,00,FD,00,38,3D,1E,4B,11,00,0A,20,20,20,20,20,20,00,00,00,FC,00,53,
79,6E,63,4D,61,73,74,65,72,0A,20,20,00,00,00,FF,00,48,39,4E,53,38,30,36,34,34,31,0A,20,20,00,90

And here is what I added to the INF file:

[NonEDIDMode_AddSwSettings]
HKR,, TotalDTDCount, %REG_DWORD%, 1 ; This shows number of DTDs to be used. ; 0-->Disable the feature.
;Following keys have 20 bytes (18 byte DTD + 2 Byte flags).
HKR,, DTD_1,%REG_BINARY%, 02,3A,80,18,71,38,2D,40,58,2C,45,00,DD,0C,11,00,00,1E,37,01 ;1440x900@60...Interlaced

Am I doing something wrong or is there any thing else I can try? I know this is not the native resolution for the monitor, but it's what I am looking to use :)

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.