HP6710b 1680x1050 @ 1432x900 DTD

HP6710b 1680x1050 @ 1432x900 DTD

I have a 6710b notebook which has a on-board 15,4" screen @ 1680x1050 res, which is just too insane high because the letters get sooooo tiny. I got the DTD of the screen (7c 2e 90 a0 60 1a 1e 40 30 20 36 00 4b cf 10 00 00 18), edited it so that it does 1432x900 (30 2a 00 98 51 00 2a 40 30 70 13 00 00 00 00 00 00 1e). After a reboot I get a very messed up screen (beyond recognition really). So I suspect the timings are off. Does anyone have a valid DTD for me?

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Wow, I'm really very surprised you had to go the DTD route to get your monitor to use a lower resolution than 1680x1050... the Display Properties didn't offer you any other resolution options? [boggle]

The DTD youused for "1432x900" is actually set up for 1280x1024, with 108MHz pixel clock:

30 2a 00 98 51 00 2a 40 30 70 13 00 00 00 00 00 00 1e

500 is 1280 and 400 is 1024

If there's no other 1440x900 timings available for your screen, I'd try the generic:

97 29 98D8 51 8420 30 50 98 13 00 00 00 00 00 00 1E

Got these from

Linux modeline parameters:
"1440x900" 106.470 1440 1520 1672 1904 900 901 904 932 -hsync +vsync

The display properties offers lower resolutions, but these all have a very different aspect ratio than 1.6 (so either I have large black blocks at the side or stretched out letters).

I used IEGD_7_0 to generate a new drivers package with your DTD string, installed them and rebooted into safe mode. I saw the new resolution in display properties, but once I activated this mode I got a bright white screen. My guess is that the pixel clock settings needs to be set differently (which is a blind guess really, because I do not know much about the timing of monitors). I also tried editing the DTD directly using the previous method I used (when I got a black screen), but it had the same results (bright white screen).

I guess I need to go by trial & error. I'll try that later tonight. Thanks for the help on correcting my incorrect EDID resolution string.

Leave a Comment

Please sign in to add a comment. Not a member? Join today