945G Express Chipset Family

945G Express Chipset Family

A whileago I had a video problem (screen blinks to black for 1-2 seconds, then back) while playing World of Warcraft. After exiting the game, my desktop showed an error saying that my "display driver had stopped responding and has recovered". I downloaded a driver update from Intel which fixed the problem.

Today Windows Update showed an update available::

Intel Corporation - Video - Intel 82945G Express Chipset Family

I installed this update and now I experience the same issue that I had before during gameplay. I tried to download the driver update (Intel Graphics Media Accelerator Driver version 15.2) as I had before, but I now get an error message after I try to install it saying "The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer's manufacturer". I've also tried the older 15.1 version. (I'm running Windows Vista Home Premium 32 bit) Mydevice managersays that I have driver version 7.14.10.1147.

I have tried to find a way to uninstall this update, but I haven't had any luck. Is there any way to remove this update? Or is there something else I can download?

22 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

By any chance do you have a Gateway system? I'm having the exact same problem.. I've done everything you have, so if you get it fixed please let me know aswell and i'll do the same.

Im using a Gateway laptop, and Im in exactly the same situation as you. Please get in touch if you find a solution to this problem. I launch Silkroad Online, and attempt to login with my character, but it freezes upon clicking my character.

It's strange how the Intel drivers worked, then Vista's broke support. What's even worse is the fact that Vista doesn't allow you to install the old 'working' drivers.

I had the same problem with my dell, what u need to do is uninstall the drivers from the device manager making sure u tick the uninstall the software box, after that the drivers will install fine!

First, lets just say Im not a pro, but this is what I think You might need to do...first of all, try the usual ways to un-install all the relevent drivers and updates you are referring to...
then you need to go into the registry editor under the tabs that are software related and manually delete all references to the said drivers and updates...caution..first make a backup on a disk of your registry....
Once you have removed all the references, drivers and updates that are corresponding to your problem, you should be able to re-install the drivers and updates that were working previously....this is not very hard to do, just keep in mind about backing up the registry first, in case you have a problem you can always re-load the old registry back to its original form in safe mode if necessary....

I to do have trouble with my Dell 82945G Express Chipset Family driver. The problem started after I got a new screen, a 22' Samsung SyncMaster 226BW.

I'm betatesting a game and my screen started to act very wierd and one day it total crash with only 4 colores. I tryed to download the driver from Intel and was too told it did not fit.

Ok I did as you said and all looked fine until I tryed to changes screen size. 1080x768 would fill the screen but everything was to wide. 1280x768, that worked before would now leave some black at toop and bottom and everything was still to wide.

Then I updated from microsoft and nor I have version:6.14.10.4410

It still seem to give me some problems with the game but the 1280x768 setting works correct now.

It may be my screen and the win2k_xp1429.exe driver that can't get along.

Gosh, i thought im the only person who has this similar problem. Im using the Intel 945GM/GU Chipset Family on a Vista Home Basic 32 bit. I was also playing CC3 Tiberium Wars and it was fine. Until i decided to install Diablo 2 and i have problems with the graphics. I have checked in Blizzard's forum and they ask me to update my driver. When i updated it, i have flickers on my screen. I downloaded the file version(15.4.3)and reinstall again, still the same problem. I uninstall the driver and reinstall it again, still has no effect. I have called Microsoft and they told me to check with Intel. I have also called HP,and they asked me to backup my datas, and do a system recovery. Before i decided to do that, i have even tried to restore system to the best settings. No effect.Shall i proceed with the system recovery?.

Oh yea, i forgot to tellyou guys, i tried installing awindows update file on the Chipset, it shows error code 80070103.

i installed version 15.4.3 von windows vista 32-bit on my 945GM too, and it causes screen flickers.

i even deinstalled it and installed the previous version (15.4) which worked just fine before. but it still flickers, seems like the 15.4.3 destroyed something, i hope its not the card!

how can intel release that driver and MS give a WHQL certificate? thats a shame.

i have a dell inspiron 640m laptop.

Same here. I have "HP Pavilion DV6245US 15.4" Entertainment Notebook PC" which has "Intel 945G Express Chipset Family" as a graphic card.

I downloaded the updated driver from intel site and installed it. Then at the admin login page, the screen keep blinking (flicking) like crazy!

Once you login, the screen is normal again. (but it also blink everytime Vista's need-your-permission-to-access dialog box shows up.)

I reinstall the old driver but the same problem still exist.

Somebody please, please, please help.

This is seriously screwed. I have the same issue with screen flickering after installing the 15.4.3 update and have been unsuccessful in fixing the issue. I want Intel to take responsibility for what they have done to my laptop. No driver should screw my computer up this bad even after uninstalling it.

Not to mention that all drivers after the one released in early feb. have had numerous crashes with igdumd.dll driver. I can play many games with the old feburary driver just fine and all lastest drivers crash with the igdumd.dll error. This can be noticed in WOW and the old driver version fix has been posted numerous times on their forums.

basically I dont see why Intels software development on these drivers keep going backwards. Get you act together and get us intel users some decent drivers to work with.

As I have already posted in another thread, I am having the same issue after the installation of the 15.4.3 driver on a Dell Inspiron notebook.
Reverting to older Intel-drivers didn't fix the issue. It must be a
registry value which causes this behaviour and that survives even after
the installation of an older version.

Intel should fix this bug as quick as possible since I have been seeing many reports of this issue popping up on various forums.

Btw, did anybody ever use the Video BIOS update from the developer
package? Could updating the Video BIOS with a version from the driver
package maybe fix the issue?

I installed 15.4.3 and suffered the same flickering problem, uninstalled... reinstalled...uninstalled..reinstalled a million times and the problem still existed.

Well guys, I have a solution!!! It is really easy to do and it requires no uninstalling/installing. You can keep the 15.4.3 driver and do the following.

Type in regedit in the search bar and open up the program

Find the registrykey: [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlGraphicsDriversMemoryManager]
"FaultInjection"=dword:00000200

Delete "MemoryManager", restart your computerand it's fixed!

I have an XPS M1210 running Windows Vista Home Premium 32-Bit.

Brilliant solution - fixed my Vaio UX380 after my many attempts at re-installation, similar to everyone in this forum!

Hi all,

I just got a reply from Intel UK. Here as follows:

Mr Johnson,

Thank you for your relpy.

I would like to bring to your attention also that the drivers on our website are there strictly for Intel boxed products, if your product was not purchased boxed but integrated into a system and drivers are used from our website it could cause damage to the system. Drivers should really be obtained from the system manufacturer webpage. As you do not have a boxed product it will not be possible to obtain assistance from us regarding this issue. Our number should you require in the future is:0044 870607 2439.

Kind regards,

Marcello P.

Intel Customer Support (EMEA)
Intel Corporation (UK) Limited
Registered No. 1134945 (England)
Registered Office: Pipers Way, Swindon SN3 1RJ
VAT No: 860 2173 47

Excellent!!!...Problem solved.

Im using a Compaq Presario V3219TU with a Vista Home Basic 32 bit.

Gold bless you.

OMG it's WORKS, thanks a lot man.

Now, what is this "MemoryManager" thing you tell me to delete?
It's not something vital to the computer, right? (not that I question your method, Thx again)

My fiance's computer is having the same issue, does anybody know how to fix this?

Sorry if this is gravedigging an old post, but she doesn't really know much about computers and is getting really frustrated (the computer is 3 days old), and I don't know what the deal is.

Thanks in advance if anyone out there knows :)

ack sorry the board was screwed up on the computer and i didn't see the other replies :P

SORRY!!

I tried to delete the Memory Manager but there is not one where you said it would be. Do you know where else i could find it?

Thx, Mike

My computer has develpoed a problem about a month ago, while I was watching a film online.

The screen blinked to black for abou 3 seconds and a message dispayed saying ( the display driver has stopped responding but recovered successfully). I have been trying to download the right recommended driver "Intel 82945G Express Chipset" buthaven't succed in doing so, as, whenever I save and run it, it says (says it isnot validated for your computer).

Is there anyone experiencing same problem or could possibly help?

You're right... I have same problem about this too...

crm solutions - http://solutions-of-crm.blogspot.com/

I just bought an E- Machine and im using Vista Home Premium... im getting the same driver not working but has recovered and i get a VGA adapter in not compatible pop up too... and and when i try to install drivers i need for it my comp says the compatible hardware doesnt exist... i am sofrustrated trying to play world of warcraft and dawn of war... anyone know how to fix this... im going to try the memory manager and see if that works...

Leave a Comment

Please sign in to add a comment. Not a member? Join today