Failure Reason: ILU03

Failure Reason: ILU03

I am an IEM working with an account who is trying to get their application listed on the Appstore but have failed three times. They have received the following message. " This is to inform you that ReverseIt! 2.0 has failed to meet Intel(R) Atom(TM) Developer Program's validation criteria. Failure Reason: ILU03 - Application launch Additional Comments: launching application from within the store and outside of the store fails. please see for troubleshooting launch issues. thank you! " The developer has gone through the article and is still having issues trying to get approved. Is there another article that I should point them to or avenue that they need to go down to get this approved. As they have tried three times, they are getting very frustrated and I want to make sure the next time they try everything works for them. Please Help!
13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

first,they must Beta Test Their application from the AppUpSM center before submitting it to validation.installing and launching an application from within the Intel AppUpSM center will elucidate the Problem that they encounter precisely,is it a missing DLL(dependencies ),or the shortcuts of the application
is not properly advertised.


Here are some suggestions to get you started:

1.) Reply to the testers validation failure message, asking for a screen shot of the error they are reporting. This may take a few days but it will give you a more detailed error and perhaps a clear direction to head in to resolve the issue.

2.) Test the MSI installer on a clean installation of Windows XP/7. This will expose common application issues and hopefully allow you to reproduce the issue the tester observed. Having a clean test environment ensures that you are replicating what the tester is doing during validation. For instructions on how to setup an easy to re-use test environment please see this article:

3.) Ensure your MSI includes the CRT Runtime. Please see this post for further detail:

4.) Check your shortcuts to ensure you do not have a problem with missing libraries. more info here:

5.) Review this list of common validation failures:

6.) Please see this post on how to Beta Test the application prior to re-submitting:

Once you have reproduced the error in your test environment, please feel free to post a screen shot so I can assist further. Best of luck.


Was your developer able to solve the launch issues and successfully beta test? Another helpful link when you get to a point where your application will not compile:

Hi Brian,

Yes, my account was able to solve everything and have successfully launched their game into the program and store. Thank you for your help with this.

Thanks for the feedback. Best of luck to you.

Brian write:
>1.) Reply to the testers validation failure message, asking for a screen shot of the error they are reporting. This may take a
>few days but it will give you a more detailed error and perhaps a clear direction to head in to resolve the issue.
cool scene-- @ folks from intel-- is this actually possible ?
do they actually send back screenshots ? As far as I know-- the reasons in accepted/rejected mail are the only reasons we would have access to.

awaiting your reply...



Hello Nalin,

The validation team cannot take screenshots of apps they have already rejected because they no longer have access to them.

Best Regards,

Hal G.

Intel® Atom™ Developer Program

Hello everyone,

I have similar problem with a twist, and it becomes even more twisted after I read message from Hal.

My application for moblin was rejected first time with the reason that it keeps working even when authorization fails, that was expected behaviour, not really a bug. I did update the software accordingly, and it worked as expected locally, i.e. worked when authorized, and did not when not. I do print out debug messages for authorization process, and I left this output printing just in case. Updated application was reject again citing opposite behaviour, refused to run when authorization succeeds, and my local version works okay - but with debug ID. The same day I sent a message to verification team asking for the output, the same debug messages I am printing out. Now it is more than two weeks, and I got no response. Now it appears that verification team has no access to the app because it is rejected and therefore I can't get the info I need. I am puzzled. What should I do now?


I got this error from Intel on Windows XP not on Windows 7. I think the problem is that Visual Studio 2008 redistribute package requires .Net Framework 3.5. But XP SP3 did not install .NET Framework 3.5. These are pre-installed in Windows 7. My suggestion is

Could Intel requests all Atom PCs that will access Atom App Store pre-install VS 2008 redistribute package and .NET Framework 3.5?

So developers do not need to include these basic Win7 packages in their program installation. Actually this should be Microsoft's XP SP4.

My suggestion is that MFC, ATL, .NET should be pre-installed in Netbooks for Atom's App Store. This can save lots of space and confusion.

I guess lots of application launch troubles are caused by lacking installation of VS 2008 Redistribute Package.


I suggest you use the Beta Test feature and check if your application really works within the AppUp Client:

Please read my responses here:

Best Regards,

Andre B.

Intel® Atom™ Developer Program

Thanks Andre,

The app in question is for moblin. The AppUp client works with Win7/WinXP only, at least that's what displays. Is AppUp client for moblin available? That would really help.


Hello Boris,

The Moblin AppUp Client is not available yet but will be released soon.

Best Regards,

Andre B.

Intel® Atom™ Developer Program

Leave a Comment

Please sign in to add a comment. Not a member? Join today