Validation team testing apps outside of Appup

Validation team testing apps outside of Appup

Hi All,


Recently I got a rejection notice and one of the items was the Validation Team (Test Team) tried to double click on the main jar of my java app and expected it to launch and run. It runs fine in Appup is what they said but double clicking the jar in a folder launched but it did not work.

When I resubmitted I said please do not try that since you need to be an appup engineer to figure out how they launched it correctly considering how Appup works. If you want to launch any java app outside of appup I am guessing the appup engineers launched it knowing the correct jvm to use (path to it) and any command line parameters including a java policy file). The reason for all that is there may be a 64-bit jvm installed and if there is a 32-bit one (enforced by appup) and depending upon install order it may launch the app but not work properly at all.

Ok someone may say does not 32-bit java apps work with a 64-bit jvm? The answer is no especially when you use jogl for gaming and other frameworks for special things like video and 3-D mapping because there may only be support for 32-bit java still.

So please do not go outside of Appup since the engineers of Appup worked really hard to get apps to work inside of it for lots of reasons and if you go outside you are probably going to not have it work.

If you want apps for appup to work outside of it the testers should make an enhancement request of Appup Engineering and have the install create a proper shortcut on the windows desktop that points to the proper jre, startup command line params at a minimum and whatever else Appup requires.




3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I figued out why Appup works and the way the validation team is doing it fails. Appup supplies the java lib path command line parameter.

When packaging for Appup using the Intel supplied packaging utility a main jar and a java library is used. Both the lib jars AND the dlls that might be needed are put into the library folder. BUT when java is launched there are TWO important command line parameters one is the -classpath  for libarary jar and the other is the -Djava.library.path for dlls is needed. The error the validation teams was getting was related to not suppling the second parameter.

The other issue here is I think Appup does not supply shortcuts and should. Why? Because with thousands of apps with different potential parameters it makes sense to have the install app (Appup) do the work not the customers. Also when de-installing Appup should remove the desktop shortcut unless again they are expecting the customer to do that which does not seem right. Intel may say well the app should uninstall the shortcut but if Appup just removes the app and it's library folders then there is no way an app can uninstall itself.


The other option is let the folks submitting do the install and deinstall. As I mentioned to one of your engineers Microsoft offers that option by allowing the app submitters to provide a link to thier install front thier website.

Again I thinks folks on Appup have done a great job but need to look at things from end to end. I can supply a way in my install to setup shortcuts and was even pointed out by that by the an engineer at Intel but that does not solve the uninstall where appup does the uninstall but would leave the shortcut to an app that does not exist anymore.

Best Regards


Leave a Comment

Please sign in to add a comment. Not a member? Join today