Intel DP67BG VT-D BIOS broken (solved)

Intel DP67BG VT-D BIOS broken (solved)

- see 3rd post


i am trying to use the vt-d function of the DP67BG Board with a i5 s2400 CPU. Both support VT-D but the implementation is broken.
I am currently using the the 1900 BIOS version, but still no success with KVM nor XEN. Using the support site results in .. ;).
I attached a screenshot showing the problems running on a Linux Kernel 2.6.37.x with BIOS version 1815, with 1900 the error still the same.

greetings Michael

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Here's what I what I was told about your issue:

The failure occurredbecause VT-d capability or extended capability values are invalid; they have all 1s. This is a BIOS issue --you will need to contact the HW vendorabout getting it fixed.

There are a number of possibilities, but the issueusually means that the BIOS vendor just put an incorrect address for the DMAR into the BIOS table,or that they have the address correct but they neglected to enable it.

David Ott

Good news,

i tested a beta 1950 bios from Intel for the DP67BG Board.
Running Linux 2.6.38 in combination with qemu/kvm and libvirt.


passthrough intel nic

So with the next bios-update it should be fine :).



Leave a Comment

Please sign in to add a comment. Not a member? Join today