How to set EPT's memory type

How to set EPT's memory type

Hi, my guest is Ubuntu 14.04, and I test my code in VMware 10.

When I launch vmx, the Ubuntu can run as VM correctly. But if  I enabled the EPT, the Ubuntu hangs. I have tried to set the memory type through mtrr, failed too.

Is there any more detail information? Except the Xen link?

May I make a suggestion? There are many questions in this forumn, and a lot of answer is reference the Xen or Manaual. I know these material is good, but could some one give a more detailed answer? I have read the Manaual serval times, and the Xen is complicate, it can not help sometime.

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I found some existing posts related to your topics and may have some glues for you:

EPT write back memory type and Machine Check exception


KVM: Enable MTRR for EPT


hi, i have tried so many times.still not work.

the strange thing is , i can see a lot of vm exit:cpuid, control register access, external interrupt. but no any response on the screen.


hi, i solved my problem.

i did not know that, my ubuntu make PAE enabled. if the PAE is enabled, PDPTE in guest not-register state must be set, and if a write to cr3 VM-exit happend, the PDPTE must be updated.

Congratulation Water!

If you could share a sample code of how you solve this issue for others to learn from, it would be very helpful.



i am sorry i could not share the's commerical.

No problem...I understand.



by the way, the operation is very simple.

1) get value of cr3, we get the base address of the pdpte.

2) then write the pdpte to guest not-register state.

Leave a Comment

Please sign in to add a comment. Not a member? Join today