Intel Architecture Code Analyzer Error

Intel Architecture Code Analyzer Error

Hi everyone,

I am new here and it is my first post on this forum.

I just started using intel Architecture code analyzer (IACA) and when I tried to run it I had the following error as output:

"Initialization failed"

I looked in the Intel Documentation but I didn't find this error in their List.

Any kind of help will be really appreciated.

Many Thanks,


19 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Can you post more detailed description of the error if possible?


Thanks for your interest.

Well when I run iaca -o output.txt apps.exe I get only :"Initilaization failed" without any other specifications, thing that make it harder to figure it where does this error come from.

By the way my application works correctly, so there is no problem form that side. I was wondering that my be I missed placed the marks:





Do not you have any error messages thrown by the Windows?

Can you search IACA directory for any log files?

You can also try to run IACA under windows debugger.If you need assistance please inform me.

No messages thrown or Logs unfortunately!!



Looks like memory(maybe heap allocation) error.It is hard to know without any meaningful description beside that "Initialization failed" message

As I advised you earlier please try to run IACA under debugger.I hope that windbg could catch the error.Before doing that you can set all exception on in windbg command prompt.Use following command sxe and rerun the IACA if there is no break into debugger on first-Chance please use sxd command and rerun IACA now it should break into debugger on second-Chance exception.


Thank you guys for all your advices.

I will come back to you when done

Ok I am waiting for your answer.


Hi I have forgotten to add that you can create IACA proces memory dump directly from task manager or process explorer.

Maybe posting on different forum will be more helpful?

do you run in Windows or Linux?


If this is Linux you should run using script




I think that @Mahieddine is running Windows.

"Well when I run iaca -o output.txt apps.exe "

I just tried both win32 and win64 release from and they worked for me

This error message usually mean the analyzer failed to load the correct dll.

check if you have any iaca directory in your path, if you have older versions of the analyzer on your computer it might have used an old dll.





Thanks for clarifying that cryptic error message.

Hi all,

I am runing iaca on a linux platform.

and I am using the iaca command and no the I followed those step to get it working :

Add the bin/ directory to the PATH environment variable.
Add the lib/ directory to the LD_LIBRARY_PATH environment variable.
Include include/iacaMarks.h in your code.

so now the iaca command is recognized by the prompt.

Hi I have a similar problem. I am getting the error "Initialization failed" as well.  I have added bin to PATH and the lib to LD_LIBRARY_PATH.I downloaded the binary and the libraries on my laptop, an Intel Westmere machine. IACA ran correctly on my laptop.

I then moved the binaries and libraries to the supercomputer Edison (, which has intel ivy bridge nodes. I set the environment variables on this machine as well.

Without an input file, the tool runs :

protonu@edison01:~> iaca
Intel(R) Architecture Code Analyzer Version - 2.1
Usage: iaca [options] <file-name>
-32 32-bit input file (default)
-64 64-bit input file
-arch <type> Architecture type: NHM, WSM, SNB, IVB, HSW (default)
-analysis <type> Analysis type: LATENCY, THROUGHPUT (default)
-o <file> Output file (default: stdout)
-graph <file> Analysis graph output file for use with graphviz
-mark <num> Show code section <num> when there are multiple marked code
sections. Use -mark 0 to show all.
-max32 Max generated 32-bit obj files
-max64 Max generated 64-bit obj files
-ignore <bool> Ignore added pop ebx / push ebx markers (default: true)
-nogather No gather bottleneck analysis
-no_interiteration No interiteration bottleneck analysis
-reduceout Output is reduced
-report Generate error report

When given an input, it fails, giving the message:

protonu@edison01:~/MicroStencilBench> iaca -64 run.125
Initialization failed

Any help will be very useful.


I see exactly same problem as mentioned above by Protonu B. I try to run with gdb which gives error code 015.

Any suggestion?

I am seeing the same issue on pleiades at NASA/Ames using (downloaded on 5 Dec. 2014.

ldd /#/#/###/VectorIntrinsics/IACA/iaca-lin64/bin/iaca =>  (0x00007ffe3fffe000) => /#//##/###/VectorIntrinsics/IACA/iaca-lin64/lib/ (0x00007ffe3fdfa000) => /lib64/ (0x00007ffe3fbb3000) => /lib64/ (0x00007ffe3f93a000) => /usr/lib64/ (0x00007ffe3f633000) => /lib64/ (0x00007ffe3f41d000) => /lib64/ (0x00007ffe3f0a1000)
    /lib64/ (0x0000555555554000)
pfe20> /#/##/###/VectorIntrinsics/IACA/iaca-lin64/bin/iaca -64 -arch SNB ./a.out
Initialization failed



Leave a Comment

Please sign in to add a comment. Not a member? Join today