System Requirements

Development Platforms

Processors

6th to 8th generation Intel® Core™ and Intel® Xeon® processors

Compatible Operating Systems

  • Ubuntu* 16.04.3 LTS (64 bit)
  • Windows® 10 (64 bit)
  • CentOS* 7.4 (64 bit)

Target System Platforms

CPU

Processors

Compatible Operating Systems

6th to 8th generation Intel Core and Intel Xeon processors
  • Ubuntu 16.04.3 LTS (64 bit)
  • Windows 10 (64 bit)
  • CentOS 7.4 (64 bit)
Intel® Pentium® processor N4200/5, N3350/5, N3450/5 with Intel® HD Graphics
  • Yocto Project* Poky Jethro v2.0.3 (64 bit)
  • Ubuntu 16.04.3 LTS (64 bit)

Iris® Pro & Intel® HD Graphics

Processors

  • 6th to 8th generation Intel Core processor with Iris® Pro graphics and Intel HD Graphics
  • 6th to 8th generation Intel Xeon processor with Iris Pro graphics and Intel HD Graphics (excluding the e5 family which does not include graphics)

† For more information, see the installation guides.

Compatible Operating Systems

  • Ubuntu 16.04.3 LTS (64 bit)
  • Windows 10 (64 bit)
  • CentOS 7.4 (64 bit)

FPGA

OpenCV and OpenVX* functions must be run against the CPU or GPU.

Processors

  • Intel® Arria® FPGA 10 FPGA GX development kit
  • Intel® Programmable Acceleration Card with Intel® Arria® 10 FPGA GX operating systems

Compatible Operating Systems

  • Ubuntu 16.04.3 LTS (64 bit)
  • CentOS 7.4 (64 bit)

VPU

Supported Hardware

  • Intel® Movidius™ Neural Compute Stick
  • Intel® Neural Compute Stick 2

Compatible Operating Systems

  • Ubuntu 16.04.3 LTS (64 bit)
  • Windows 10 (64 bit)
  • CentOS 7.4 (64 bit)

Intel® Vision Accelerator Design

Supported Hardware

  • Intel® Vision Accelerator Design with Intel® Arria 10 FPGA

Compatible Operating Systems

  • Ubuntu 16.04.3 LTS (64 bit)
  • Linux* kernel 4.15.0-38

Additional Software Requirements

External Dependencies