Filters

Forum topic

OpenMP programming for multiple sockets server ccNUMA

Hi,

Authored by rahman, mohammad khaledur Last updated on 07/18/2019 - 15:32
Forum topic

Crash when compiling certain OpenMP code

My OpenMP code, which had been compiling with under ICC through version 18.0.0, now causes a segfault in ICC when I attempt to compile it.

Authored by ben p. Last updated on 06/29/2018 - 11:25
Forum topic

Intel Openmp hangs during program exit

I have an application which uses openmp. It is compiled (using Intel Composer XE 2017 update 5) for Suse but runs on Ubuntu Linux with real time extensions.

Authored by Duvvuri, Muralidhar Last updated on 08/10/2018 - 11:40
Forum topic

OpenMP + lambda capture = icc internal error

C++ compiler 18.0.2 is crashing when using OpenMP and C++11 lambda capture.

Here is a minimial crashing example:

Authored by durocher, arnaud Last updated on 06/01/2018 - 10:30
Forum topic

OpenMP array reductions in templated functions

Hello,

Authored by Peter C. Last updated on 06/01/2018 - 10:30
Forum topic

ICE with OpenMP and missing increment

A typo led me to discover that if the increment (e.g., ++) on an OpenMP parallel for is missing, then the compiler reports an internal error rather a normal error message such as I would expect.  H

Authored by Kensler, Andrew Last updated on 11/27/2018 - 13:13
Forum topic

-qopt-report not reporting all OpenMP pragmas inserted by -parallel

Hello,

Authored by Joao B. Last updated on 06/01/2018 - 10:30
Forum topic

OpenMP untied task and taskyield does not work as expected

Hi,

Authored by Geiser, Georg Last updated on 06/01/2018 - 10:30
Forum topic

OpenMP parallel loop with ordered section is slow

In the attached C sample I try to parallelize formatted writes to file by doing the formatting into a string buffer inside OpenMP parallel for and then writing the buffer to file with fwrite (insid

Authored by ondracka, pavel Last updated on 03/08/2019 - 12:43
Forum topic

Problems when combining OpenMP with AVX/SIMD instructions

I have a strange problem when I try to use AVX/SIMD instructions in the kernel of an OpenMP parallel for loop.

Authored by Stefan I. Last updated on 06/01/2018 - 10:30