Optimization

VTune not connecting to Sun JVM Application

Hi,

I am new to VTune and have downloaded the trail version for now. My application is pure Java based and is using Hotspot JVM 1.8. Right now I am trying to profile the application locally on my Windows 7 Desktop but eventually will move this application to RHEL v6.

I am trying to profile my application using VTune Amplifier XE 2015 Update 2 but haven't got any success.

Is there a step by step guide the steps. I tried to look around a lot but couldn't find anything concrete. I will appreciate if someone can share some thoughts.

Thanks.

 

integration with VS 2015, no 64-bit version, does not recognize Windows 10

I had installed Parallel Studio XE 2015 Update 4 on a Windows 8.1 machine.  Integration into Microsoft Visual Studio 2013 worked with Inspector, Amplifier, and Advisor showing up in the VS menu bar.  Integration into Microsoft Visual Studio 2015 worked only for Amplifier.  I noticed in the "Program Files (x86)\Intel\VTune Amplifier XE 2015" folder the *.msi files for VS 2010, 2012, 2013, and 2015.  However, in the Inspector and Advisor folders I saw only the *.msi files for VS 2010, 2012, and 2013.

Linux Surface sharing (intel/vaapi)

Hi all,

I'm wokring in linux and I have a encoder/decoder that it is encoding and decoding good. Now, I want to perform a HW render so, I want to share the surfaces. I'm getting the surface from the MemID from Intel and I create all the necessary stuff to set up the VASurfaceID in VAAPI but it always returns invalid VASurfaceID.

I have perform the same idea under windows using DXVA and it works perfectly, So, there is any clue about why using VAAPI when vaCopySurfaceGLX function is executed to copy the VA surface to VA/GLX surface it returns bad VASurfaceID?

Newbie

I searched several times before posting this.

We have a workflow application server with BerkeleyDB running on Windows 2012 - it is used for some critical back office operations at a leading Bank with upto 1000 concurrent users . The application runs on a machine with 

What is syntax for broadcast decorator?

The ISE doc only describes the decorator syntax with the single example {1to16} (document 319433-022 page 7).

I would assume that generally you write {1ton} where n = the full vector size / the single element size.  But it would be nice to specify this exactly.

However, GNU `as` will not accept {1to4] or smaller.  Furthermore, it does not accept a broadcast decorator with a 128- or 256-bit vector size.  If I use .byte to assemble 128- and 256-bit instructions, the disassembler shows the {1to8} or {1to16} decorator regardless of VL.  Example:

fortran link-error

Hi guys,

im using Intel composer XE 2011-VS 2008 and linked with abaqus 6.10,and the link was tested and working fine,however when i tried to use abaqus cmd line to submit an analysis i got  this error. Anyone has any clue whts the source of  this kinda error??

 

ifort: command line remark #10279: option '/QxW' is deprecated and will be removed in a future release. See '/help deprecated'

Thanks and any help is really appreciated

NAMD segmentation fault when running with mpirun(intel 2015)

I had compiled NAMD 2.10 using intel 2015 compiler suite. I saw the benchmark for intel MIC card , so i am trying to benchmark NAMD with host processor only configuration. Though the following seems to me application related issue , but as i have used intel compilers  , so i have posted this issue here.
Presently i am benchmarking the application on my system (CentOS 6.5 ,Xeon 2670 v3), though i will incrementally add optimization flags as per my architecture.

Subscribe to Optimization