Intel® Cluster Ready

qdel not killing all processes started under Intel MPI

Hi, when we run using Intel MPI with Hydra process manager (in a script submitted with qsub-- this is with OGS/GE 2011.11p1 on ROCKS 6.1 on a small blade cluster), qdel does not fully kill the job except when the the jobscript runs on the frontend. I have to kill the processes started by mpirun manually if the jobscript runs on a compute node. This is not a problem with OpenMPI.

Any ideas or suggestions on how to proceed with troubleshooting this would be much appreciated.
Thanks,
Noah

Using Intel® MPI Library 5.0 with MPICH based applications

Why it is needed?

Different MPI implementations have their specific benefits and advantages. So in the specific cluster environment the HPC application with the other MPI implementation can probably perform better.

 Intel® MPI Library has the following benefits:

  • Developers
  • Partners
  • Professors
  • Students
  • Linux*
  • Server
  • Advanced
  • Beginner
  • Intermediate
  • Intel® Cluster Toolkit
  • Intel® Trace Analyzer and Collector
  • Intel® MPI Library
  • Intel® Cluster Studio
  • Intel® Cluster Studio XE
  • Intel® Cluster Ready
  • Message Passing Interface
  • Cluster Computing
  • Development Tools
  • MPI Rank Binding

    Hello all,

    Intel MPI 4.1.3 on RHEL6.4: trying to bind ranks in two simple fashions:(a) 2 ranks to the same processor socket and (b) 2 ranks to different processor sockets.

    Looking at the Intel MPI Reference Manual (3.2. Process Pinning pp.98+), we should be able to use options in mpiexec.hydra when the hostfile points to the same host

    -genv I_MPI_PIN 1  -genv I_MPI_PIN_PROCESSOR_LIST all:bunch
    -genv I_MPI_PIN 1  -genv I_MPI_PIN_PROCESSOR_LIST all:scatter

     

    Intel MPI Using

    Hello everyone

    First i have to provide this information:

    1- i have instaled the latest version of Intel MPI.

    2- i have to use it through Ansys HFSS 15 x64 which is a EM-software.

    3- HFSS dont have any problem with discrit processes (for ex. 15 paralel process will share trough 3 computer on network correctly)

    4- i need to use memory of other computers on the network, so need distribute the RAM usage.

    5- the error i got every time is "authentication faild" or "unable to create child process in hosts" (or somthing like these)

    INTEL-MPI-5.0: -prepend-rank on the mpirun command line does not work

    Dear developers of Intel-MPI,

    I found, that the helpful option   -prepend-rank   does not work when launching  a parallelized Ftn-code with mpirun when using INTEL MPI-5.0 :

           mpirun -binding -prepend-rank -ordered-output -np 4 ./a.out

    The option actually has no effect with INTEL MPI-5.0 (with INTEL MPI-4.1 it worked). No rank-numbers are prepended on the display to the output lines of the program.

    INTEL-MPI-5.0: Bug in MPI-3 shared-memory allocation (MPI_WIN_ALLOCATE_SHARED, MPI_WIN_SHARED_QUERY)

    Dear developers of Intel-MPI,

    First of all:   Congratulations, that INTEL-MPI now supports also MPI-3 !

    However, I found a bug  in INTEL-MPI-5.0 when running the MPI-3 shared memory feature (calling MPI_WIN_ALLOCATE_SHARED, MPI_WIN_SHARED_QUERY) on a Linux Cluster (NEC Nehalem)  by a  Fortran95 CFD-code.

    Ask for suggest to configure and run parallel program in cluster

    Dear all,

    I have a cluster with two kinds of nodes joined into parallel calculation: the first kind is the nodes with 2 CPUs and 4 cores in every CPU, the memory in every node is 32 GB, the second kind is the nodes with 4 CPUs and 8 cores in every CPU, the memory in every node is 256 GB. All nodes have Windows Server 2008 HPC in stalled and they are all joined into one domain controlled by another node (which is not joined into the calculation). I launched the job by the following command:

    What’s new in Intel® Cluster Checker version 2.2

    Intel® Cluster Checker version 2.2 is an update in conjunction with Intel® Cluster Ready Architecture Specification version 1.3.1 release and also adds additional functions and capabilities.

    Version 2.2 includes:

  • Developers
  • Partners
  • Linux*
  • Advanced
  • Beginner
  • Intermediate
  • Intel® Cluster Checker
  • Intel Cluster Ready
  • Intel Cluster Checker
  • HPC
  • clusters
  • Intel® Cluster Ready
  • Cluster Computing
  • MPI 4.1 fails to end gracefully when ranks > 2000

    I am testing Intel MPI 4.1 with test.c (the provided test program).

    Whenever I run > 2000 ranks the program executes correctly but fails to end gracefully.

    Running:

    mpiexec.hydra -n 2001 -genv I_MPI_FABRICS shm:ofa -f hostfile ./testc

    It stalls at 

    ...

    ....

    Hello World: Rank 2000 running on host xxxx

    ##<stalls here; does not return to command prompt>

    (If I use -n 2000 or less, it runs perfectly.)

    I have testing 3000 ranks using OpenMPI, so it doesn't seem to be a cluster/network issue.

     

    Subscribe to Intel® Cluster Ready