Intel® Performance Tuning Utility (Archived)

Finding Intersocket QPI

Hi,

I'm unable to find any help for vtbwrun which will help in getting the QPI details. I want to check the Intersocket QPI of my application on Nehalem. When I run the vtbwrun -r I can get the "# IOH reads" in the QPI information. But what I want to find is the use of QPI links between CPU sockets(Intersocket QPI). How can I find this information using Intel performance tuning utility?

Below is the information that I can get using the Intel PMU. But I need the details like the QPI utilization between processors.

unknown(s) in Statistical Callstack x86_64 Windows XP

Hi,

when profiling my binary with statistical callstack, a lot of runtime is executed
in "unknown(s)". It seems, that all callstacks contain at least one entry with labeld
with unknown(s) and these are those that make up most of the runtime.

At the moment, I have no idea, where these entries come from, I checked the
pdf files, they seem to be correct.

What could be the reason for this?

I'm using PTU 4.0 update 3 for win64 and my executable is also 64 bit

Thanks and regards,

Reiner

L3 cache events for new processors

Hello,

I am trying to profile L3 cache behaviour for two different architectures, and I encounter a lot of difficulties.

These two architectures are based on X7460 and X7560 Intel Xeon processors.

I am using VTune 9.1 and PTU 4.0 Update 3 to sample the events.

PTU gives me a list of available events for each architecture.

For
the X7400 series, I have many many events about L1 and L2 caches access
(load, store, self, both_cores, demand, prefetch). Actually, 30% of the
available events are about cache. But NOTHING about L3 cache.

vtssview not working

I can't see to get vtssview to work after attaching to a running service, below is the output from my run. I'm running W2003 R2 on a I69.

C:\\>vtssrun log -a 9296

C:\\> dir log

Directory of C:\\log

11/17/2010 09:21 AM .

11/17/2010 09:21 AM ..

11/16/2010 12:58 PM 13,935 436-9296.vtss
11/16/2010 01:33 PM cache
11/16/2010 12:56 PM 126 history.log
11/17/2010 09:21 AM 188 ModuleAssociationCache.xml
11/16/2010 01:33 PM 582 vtdpview.log
11/16/2010 01:03 PM 38,912 vtscgdata.db
5 File(s) 53,743 bytes

i5 Losing Performance

Hi,
I recently replaced mygraphics cardand noticed that my i5 had lost performance in the windows rating, is this normal and is there anyway of safely squeezing more out of my CPU.

Any advice much appreciated:)

thanks

Dave

Spec:

Processor Intel Core i5 CPU 660 @ 3.33GHz 6.4

MB- P55A-UD3R BIOS F12
ATI Radeon 5850
4.00 GB RAM (DDR3)

Win 7 64 Bit

Subscribe to Intel® Performance Tuning Utility (Archived)