Python issues with the Intel® MPI Library up to version 5.1.3

Intel® MPI Library versions before 2017 (<= 5.1.3) use Python 2 scripts for some infrastructure components - mostly related to the deprecated MPD startup mechanism. One example here is the mpiexec (symbolic link to mpiexe.py) script which uses the general Python shebang sequence.

#!/usr/bin/env python

While these scripts were written for Python 2, they are not necessarily Python 3 compatible. Therefore, issues might appear if the user is leveraging a Python 3 environment - implicit or explicit.

In order to work around the problem, the user can either use the Hydra startup infrastructure or make sure that the default Python environment is Python 2.

The current Python version can be determined using:

$ python -V

 

 

 

Para obtener información más completa sobre las optimizaciones del compilador, consulte nuestro Aviso de optimización.