After update to 3900 intel xdk not starting [Ubuntu]

After update to 3900 intel xdk not starting [Ubuntu]

I've upgraded my intel xdk to the new version and I can't open the program. I tried to reinstall, with and without sudo, launching it from .sh file, formating ubuntu, and it is imposible. How can I open the program or debug this action?

Please this issue is very important for us.

publicaciones de 9 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Which version of Ubuntu are you using? Are you using Ubuntu 64-bit or 32-bit? Which XDK did you download and install? 32-bit or 64-bit? Did you install the XDK as a "local user"? A local install should end up in your home directory.

引文:

Paul F. (Intel) 写道:

Which version of Ubuntu are you using? Are you using Ubuntu 64-bit or 32-bit? Which XDK did you download and install? 32-bit or 64-bit? Did you install the XDK as a "local user"? A local install should end up in your home directory.

I'm using Ubuntu 16.04 LTS 64-bit. I downloaded 64-bit. I installed it "local user" (home directory) and I tried as root too (/opt directory).

Thanks for your reply 

Please provide a video or series of screenshots that show precisely what is happening (or not happening).

引文:

Paul F. (Intel) 写道:

Please provide a video or series of screenshots that show precisely what is happening (or not happening).

Nothing is happening. No errors, no warnings, nothing. I can send video or screenshots, but... 
I have been tried to launch it from icon and it seems to start, but, finally, the icon disappear and program keep been closed. I tried to open it from the shell too, and nothing happened.

I have to say that i'm working over intel xdk for 1'5 years. 

Exists any execution log? 

 

Yes, there is an "xdk.log" file that is created each time the XDK starts. It should be located underneath the ~/.config/XDK folder. The precise location moved as a result of this upgrade, so you might find two copies (old version and new version). That file will only be created if the XDK proper actually started. If the shell script is failing, it's not likely to show up in that file.

I just performed an upgrade on my Ubuntu 16.04 64-bit image and it installed and ran without issue.

Here's what ps reports as the command for a "local" install:

  • ~/intel/XDK/bin/nw ~/intel/XDK/xdk --enable-logging

If you use that at the command-line it should start (assuming a similar installation).

Otherwise, after it started, I locked the launch to the start bar, and this is what it generated:

[Desktop Entry]
Exec=/home/ubuntu/intel/XDK/xdk.sh
Icon=intel-xdk
Type=Application
Terminal=false
Name=Intel XDK
GenericName=Intel XDK
Categoreis=Development:Intel XDK

Where "ubuntu" is this machines home folder, which you'll have to change to match your system. That file is named "intel-xdk-app.desktop" and is located in the "~/.local/share/applications" folder and has "rwx" permissions for the user, only (i.e., chmod 700).

Hope that helps, I'll get further clarification from the appropriate engineer when I can track him down. :)

I just confirmed that the "xdk.sh" script is what you should be using the start the XDK (the one referenced in the desktop file is the script you should be using the start the XDK). Is that the one you are attempting to use to start the XDK?

Alternatively, if you try something like this does it work?

$ ~/intel/XDK/bin/nw ~/intel/XDK/xdk --enable-logging &

 

I had the same problem. I used 

  • ~/intel/XDK/bin/nw ~/intel/XDK/xdk --enable-logging

And looked that libgconf-2.so.4 isn't installed. apt-get install libgconf-2-4 and all is done (for me)!

Thanks! :-)

Deje un comentario

Por favor inicie sesión para agregar un comentario. ¿No es socio? Únase ya