Parallel Studio XE 2011 installation problem

Parallel Studio XE 2011 installation problem

I have the following strange problem: I installed the latest PS2011 XE on our cluster (officially unsupported CentOS system), in a non-standard location (not /opt/intel). We have a number of older Intel compilers
installed with licenses, but I installed in a fresh tree not to mess up
the production environment. Since the person taking care of our license servers was not responding, I just installed the eval license thinking that I could fix the licensing issues later. Well, I could not! Nowhere could I find any kind of registration tool, nor any obvious license file belonging to this installation. So I tried running the installer again, but it said I had to uninstall the existing install first. I did this the quick way with rm -rf /path/to/PS2011XE, and ran the installer again. Same error! So I snooped around in every possible location I could think of (including home of root), trying to find the spot where the installer gets the faulty information from. No luck, and now I'm stuck. And not very happy. Any help appreciated.

Best regards,

publicaciones de 3 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.


Parallel Studio is installed
using RPMs which keep install data in the RPM database. To uninstall one or more Parallel Studio components
it is recommended that the uninstall scripts provided for a particular Parallel
Studio component be used to uninstall the component.

Can you recover the directories /
files that were manually removed and then
use Parallel Studios uninstall scripts?
If recovery is not possible then manual manipulation of the RPM database
may be required. Information about RPM can
be found in the man pages.

In regards to licensing, I may
need more information about the error you were receiving related to licensing
and also the type of license you have and how you have licensing configured
(single user or floating license using a FlexLM license server). However, you can check the INTEL_LICENSE_FILE
system variable to see if it is set. If
it is set, it may provide the correct path where the license file is located.



Aah! Of course! RPMs... Thank you Rob! I should of course have realized this, but I didn't examine the installation bundle very carefully. Let me comment on the installer issue a bit: This method of installation is not very good for our purposes. We are operating a rather large HPC cluster (TOP500). We need to have the Intel compilers and libraries available throughout
the system, which means installing them on a shared disk. Whenever you log on to the frontend system you are allocated a node from a pool of nodes for load balancing purposes. Since the installer utilizes the system RPM database, you can not know on which actual physical system the compilers were installed. In addition, when any given node goes down the node gets reinstalled from scratch, which means we lose the RPM database anyway, unless of course we would add the Intel installer(s) the the system installation system, but this is quite cumbersome from many perspectives. Losing the RPM database is of course no problem, until we need to install some additional component (like ArBB) which then obviously will refuse to install because of lacking dependecies... which means reinstalling everything from scratch again. No biggie, but a bit cumbersome.

Regards, Jonas

Deje un comentario

Por favor inicie sesión para agregar un comentario. ¿No es socio? Únase ya