Inspector reports deadlock, but "Lock owned" code location is missing.

Inspector reports deadlock, but "Lock owned" code location is missing.

Imagen de dimon7

Hi all,

While testing my app with theInspector,I've met the following issue.
Inspector detected "deadlock" problem in my App, but showed only two code locations: "Allocation site" and "Lock wanted". Normally, it also shows a "Lock owned" code location when deadlock detected, but in this case it's missing.
It's not clear for me, what could it mean?
I had an idea that critical section, may be,was not initialized, but it seems to be Ok. The application didn't hang during execution.
Does anybody knowthe explanation of this? What kind of bug in my App can lead the Inspector to such behaviour?
Thanks in advance.

publicaciones de 3 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.
Imagen de Sergey Kostrov
Quoting dimon7 ...Normally, it also shows a "Lock owned" code location when deadlock detected...
...
I had an idea that critical section, may be,was not initialized...

A critical section objecthas several states and one of them is"initialized-nobody-owns" and a recursion count of the object
in that case is 0. From the state"initialized-nobody-owns"it could go to the"deleted" stateor "owned-by-somebody" state.
Sorry if my respnonse looks for you too generic.

Best regards,
Sergey

Imagen de iliyapolak

The best method to troubleshoot such a issue is touse windbg which has extensive commands and metacommands to deal with possible deadlock situation.

Inicie sesión para dejar un comentario.