lightweight-hotspots data does not make sense

lightweight-hotspots data does not make sense

I used amplxe-gui to generate a lightweight-hotspots command line which I then used against a running processs. The resulting data did not make sense when viewed in the gui. After running for many million iterrations of the same processing for 15 minutes the data included code paths that I know are never executed.
I took the exact same command line and changed "-collect lightweight-hotspots" to "-collect hotspots" which I then used against the same running process (the process never stopped). The resulting data looked correct, viewing in the gui showed exactly what I would expect and did not include any of the non-sensical results I was seeing with "lightweight-hotspots".Are there any known issues with using lightweight-hotspots in terms of producing the wrong results?thanks, jon.

publicaciones de 5 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.
Imagen de Peter Wang (Intel)

Probably you used lightweight-hotspot, which has default settings - 1. run shortly session; 2. result storage is 100MB limit

My opinion is to use command in this way:
amplxe-cl -collect lightweight-hotspots -follow-child -target-duration-type=medium -data-limit=1000 -- your-program

Regards, Peter

In my experience, the analyzer doesn't handle a .tb6 data file of 200MB or more, so you must control the sampling rate either by increasing target-duration, as Peter advised, or by specifying increased sample-after values for individual events. The defaults are set for running up to 1 minute with few threads.

The command line I uses was generated by the gui and already had --data-limit=100. I'm also using --duration 60 so maybe that overrides the --data-limit.I did check and my .tb6 file was 300+MB so it is over the 200MB limit you mention.We'll reduce the time and see if a smaller resulting data file helps.thanks, jon.ps. Even though I subscribed to this thread I don't seem to get notifications when someone posts :(

Even limiting the collection such that the resulting .tb6 file does not seem to help.We continue to see results that just don't make sense.thanks, jon.

Inicie sesión para dejar un comentario.