mpitune: Error in thread 'MTWTN_0': 'NoneType' object has no attribute 'group'

mpitune: Error in thread 'MTWTN_0': 'NoneType' object has no attribute 'group'

Hi, I tried to run mpitune for analyzing the Bcast algorithm only but I got this error. If I take it out the "--os" option, I still see the same 'NoneType' object has no attribute 'group' message that shows up on some of the tests. Why is that?

$ mpitune -of ./asdf.cfg -verbose -fl shm:ofa -hf ~/hostfile --app \\"mpiexec -n 256 ./asdf.exe\\" --os I_MPI_ADJUST_BCAST

06'Jul'12 18:12:21 | MTWTN_0 : Chosen default
06'Jul'12 18:12:21 | MTWTN_0 : Obtaining default values in critical mode...
06'Jul'12 18:12:24 | MTWTN_0 : Complete. Default values is: 7:0-2147483647
06'Jul'12 18:12:24 | MTWTN_0 : Default option value is: 7:0-2147483647
06'Jul'12 18:12:24 | MTWTN_0 : Length of algorithms list is 0. Default value for option will be used.
06'Jul'12 18:12:24 DBG | Load environment from file (as dictionary): ./asdf.cfg
06'Jul'12 18:12:24 ERR | Error in thread 'MTWTN_0': 'NoneType' object has no attribute 'group'
06'Jul'12 18:12:24 CER | A critical error has occurred!
Details:
--------------------------------------------------------------------------------
Type : exceptions.AttributeError
Value : 'NoneType' object has no attribute 'group'
--------------------------------------------------------------------------------

publicaciones de 2 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Hi Lui,

Could you please attach 'asdf.cfg' to the reply. It seems to me that something wrong with regexp in this file.

Regards!
---Dmitry

Inicie sesión para dejar un comentario.