Can't get GPU Device on IvyBridge platform

Can't get GPU Device on IvyBridge platform

I am using IvyBridge platform, and have installed the Latest OpenCL SDK 2012. But in my helloworkd opencl programme. I can only get CPU Device while can't get GPU Device. My OS is windows 7 64bit. Below are some informations(platform, extension, etc)I printed when run my program:

FULL_PROFILE index.html:112

OpenCL 1.1 index.html:114

Intel OpenCL index.html:116

Intel Corporation index.html:118

cl_khr_fp64 cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_intel_printf cl_ext_device_fission cl_intel_exec_by_local_thread cl_khr_gl_sharing cl_intel_dx9_media_sharing index.html:120

Intel Core i7-3720QM CPU @ 2.60GHz index.html:135

Intel Corporation index.html:137

OpenCL 1.1 (Build 31360.31441)

I used different way of sample to get device. Firstly I got a platform, and then got device like this:
clGetDeviceIDs(platform_id, CL_DEVICE_TYPE_GPU, 1, NULL, &num_devices);
It works for CPU but not GPU.

My graphics driver is the latestest with HD4000. Anyone can help on this? Thanks

Jin

publicaciones de 3 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Hi Jin,

You should be able to get both the CPU and GPU devices on IvyBridge with HD4000. What error message are you getting trying to get the device? Can you post your sample code here?

Thanks,
Raghu

Hello Jin,In other topics it is discussed that your monitor should be connected toHD4000, otherwise it is disabled. May be this is the isuue.Sorry to interrupt, but i'm also interested in HD4000 OpenCL issue and currently reading all topics connected:)

BR,
Mikhail

Deje un comentario

Por favor inicie sesión para agregar un comentario. ¿No es socio? Únase ya