ERROR - A sampling session is already in progress

ERROR - A sampling session is already in progress

Hello,

if I exit the running application with ctrl-c, I get the following error each time I want to launch Amplifier:

ERROR - A sampling session is already in progress - Abort current run.
Error in sampling collector. Error code - 57
Error: Sampling session is already in progress.

The only solution is to reboot the system.
How can I get rid of this error to be able to launch other experiments with Amplifier?

Thank you.

Regards,
Oleg

publicaciones de 8 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Hi Oleg,Which OS you were running on?

-Vladimir

it's RHEL 6.2

First of all, check if your application process really exited after ctrl-c.Then, check if the amplxe-runss process is running. Kill it.If the two above didn't help, unload the sep driver (cd to the 'vtune-install-dir/sepdk/src/' and run rmmod-sep3) and load it again (run the insmod-sep3).

Which version of VTune Amplifier you were using? (amplxe-cl -version)

-Vladimir

thanks for your quick response.

about the first two points: yes, I checked that no amplxe process was running.
I'll try the third one next time this problem happens again

$ amplxe-cl -version
Intel VTune Amplifier XE 2011 Update 8 (build 221625) Command Line Tool

Regards,
Oleg

Hi,

I am using VTune Ampl. XE 8th Update on SLC5 derieved from RHEL 5 and have the same problem.

Actually I am not allowed to reboot the system, since there are other jobs running.

I was starting a profiling job from command line, which never really started.

Hence I killed the job.

Running the profiling job again returns the ERROR as mentioned here:

ERROR - A sampling session is already in progress - Abort current run.
Error in sampling collector. Error code - 57
Error: Sampling session is already in progress.

Removing the kernel driver is a not ending process, it just never stopped.

I really killed nearly all processes running under my user name, but no effect.

So, is there a fourth suggestion?

Thanx,
Stefan

Update: The machine seems to be dead now. No ssh, no ping.

Using ctrl-C to terminate sampling collection is not recommended.
Use "amplxe-cl -command stop -r r00??" to stop running data collection.

Fourth method is to kill all running processes of VTune Amplifier, anduse rmmod to remove sep & pax drivers manually, you mayuninstall/reinstall the product -if uninstaller doesn't work, you canremove vtune modules (components) manuallythen reinstall the product, check:
# rpm -qa intel-vtune*
intel-vtune-rdc_common-9.1p-432
intel-vtune-amplifier-xe-sep-221625-11.0-7
intel-vtune-amplifier-xe-gui-221625-11.0-7
intel-vtune-core-9.1p-432
intel-vtune-amplifier-xe-cli-221625-11.0-7
intel-vtune-rdc_core-9.1p-432
intel-vtune-amplifier-xe-cli-common-221625-11.0-7
intel-vtune-runtimelibs-9.1p-432
intel-vtune-amplifier-xe-gui-common-221625-11.0-7
intel-vtune-amplifier-xe-cli-221625-11.0-7
intel-vtune-amplifier-xe-common-221625-11.0-7
intel-vtune-doc-9.1p-432
intel-vtune-rdc_runtimelibs-9.1p-432
intel-vtune-amplifier-xe-doc-221625-11.0-7

-Peter

Thanks for the fast reply.

amplxe-cl -command stop -r r00??

is unfortunately not helping, it returns:

Fatal error: Cannot detect running collection to deliver command.

Again I killed all processes and returned into the same issue, an unusable sampling driver.

Afterwards I had still the error as mention in the beginning.

I did not remove the kernel modules, since this lead already into a dead host.

Thanx,
Stefan

Inicie sesión para dejar un comentario.