openning results: "Current license is valid only for results collected on Intel(R) Many Integrated Core Architecture"

openning results: "Current license is valid only for results collected on Intel(R) Many Integrated Core Architecture"

Hello.we recently installed VTune Amplifier XE 2011 Update 5 and found out that when openning results we always get an error in the GUI:"0x4000001f (No valid license) -- Current license is valid only for results collected on Intel Many Integrated Core Architectture"
The message is clearly misleading since the analysis has been performed with the same Amplifier XE on the same Nehalem machine.
I found that pressing "Re-resolve" button brings me back access to results.
That is all very good: the problem being just a misleading error message and 10 seconds for Re-resolving.
But I found in the Context Menus the following description of "Re-resolve":"Run a new analysis using the same analysis type configuration as of the selected result file"I am positive, my application did not run on the system when I pressed "Re-resolve". Is this another misleading piece of documentation?Thank you,Dima

publicaciones de 7 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Dima,

This seems to be a rather uncommon error that appears to have
various causes. I will take this forum thread
private so that I can gather serial number and other pertinent information to
troubleshoot the issue with you.

Thank you for pointing out the re-resolve description in the
on-line documentation. I will get this
fixed. The description for Re-resolve
and Open should read similar to Finalize the selected result again.
You may use this option after changing the search directories settings to
enable updating the symbol information.

- Rob

Hi,since the issue was resolved I'd rather get out of private back into public space. In our case the issue was caused by a stray old license file hiding in /opt/intel/licenses that was not compatible with the current network license.Even if INTEL_LICENSE_FILE environment variable points to the network license, the license files in the default license directory might influence the software.Let me thank you again for the support we received.-- Dima

Hello,

 

I have the following issue after running any vTune Amplifier analysis for a hello world application:

"Error 0x4000001f (No valid license) -- Your license file is unavailable for undetermined reasons. The error code is `-158'."

Environment:

 - host system: Gentoo x86_64

 - non-commercial license

 - dev-lang/vtune-13.1.12.305106

 

Thank you.

Imagen de MrAnderson (Intel)

Hi Nikita:

When installed, did you supply the serial number or a license file?

What is the output of the command 'echo $INTEL_LICENSE_FILE'?  It should specify the directory that contains the license file(s), typically, /opt/intel/licenses.  Are you sourcing the amplxe-vars.sh file?

Regards, MrAnderson

Cita:

MrAnderson (Intel) escribió:

Hi Nikita:

When installed, did you supply the serial number or a license file?

What is the output of the command 'echo $INTEL_LICENSE_FILE'?  It should specify the directory that contains the license file(s), typically, /opt/intel/licenses.  Are you sourcing the amplxe-vars.sh file?

Hi MrAnderson,

 

When I requested the SW I received an email with "Your product serial number is: NVKT-MNGZSLTT".

My distribution asked me to provide a license file at /opt/intel/composerxe-2013.12.305106/licenses/*.lic before installation. What I did is I created license.lic file with "NVKT-MNGZSLTT" string inside. After that installation proceeded successfully. But I encounter the issue above when trying to analyze any profiling results.

Again, I do not have any license file from Intel. Only the serial number, which was sufficient for the installation, but not for usage.

Hi MrAnderson,

 

When I requested the SW, I received an email with "Your product serial number is: NVKT-MNGZSLTT".

I installed vTune Amplifier using my distribution package manager. It asked me for /opt/intel/composerxe-2013.12.305106/licenses/*.lic file before the installation. What I did is I put "NVKT-MNGZSLTT" string into license.lic file. After that installation proceeded successfully. Now I am able to run both GUI and CLI. But any attempt to analyze any profiling data leads to the error described above.

amplxe-vars.sh script does not export INTEL_LICENSE_FILE variable for me. The output is:

$ . /opt/intel/composerxe-2013.12.305106/amplxe-vars.sh
Copyright (C) 2009-2013 Intel Corporation. All rights reserved.
Intel(R) VTune(TM) Amplifier XE 2013 (build 305106)

Inicie sesión para dejar un comentario.