Trying to install SDK on a linux system

Trying to install SDK on a linux system

Imagen de John Russell

Greetings,

I am looking to install on a Linux system, CentOS 5.4, with an NVIDIA GPU dev SDK installed. The CPU is a Core 2 Duo P9300. Does that count as a 9000 series or would I be wasting my time to try to install the Intel SDK?

Thanks,
JR

publicaciones de 5 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.
Imagen de Uri Levy (Intel)

Hi John,

Yes, ourSDK supports theCore 2 Duo P9xxx processors series (and P9300 in particular).

Thanks,
Uri

Imagen de John Russell

Thanks Uri...now for the real problem. When I try to install, it appears there are a few things missing and/or out of date. I can find my way around 'nix systems ok but am installation- and lib-challenged. Below is a capture of my attempt to install OpenCL. Any insight to packages needing installation and/or updates are greatly appreciated.

[root intel]# rpm -i intel_ocl_sdk_1.1_beta_lnx_64.rpm

error: Failed dependencies:

libc.so.6()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libc.so.6(GLIBC_2.2.5)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libc.so.6(GLIBC_2.3.2)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libc.so.6(GLIBC_2.3.4)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libc.so.6(GLIBC_2.3)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libdl.so.2()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libdl.so.2(GLIBC_2.2.5)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libgcc_s.so.1()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libgcc_s.so.1(GCC_3.0)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libgcc_s.so.1(GCC_3.4)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libgcc_s.so.1(GCC_4.0.0)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libm.so.6()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libm.so.6(GLIBC_2.2.5)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libnuma.so.1()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libnuma.so.1(libnuma_1.1)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libnuma.so.1(libnuma_1.2)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libpthread.so.0()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

librt.so.1()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

librt.so.1(GLIBC_2.2.5)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libstdc++.so.6()(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libstdc++.so.6(CXXABI_1.3)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by intel_ocl_sdk_SUSE+11.1-1.1-1.x86_64

[root intel]#

Imagen de Romain Dolbeau

Apparently, the version required by the SDK for some software is higher than what you have, and you need to upgrade.

You can find the exact package supplying a library by

1) looking for the location of the file itself in the filesystem
2) using rpm to find the exact package supplying that file

i.e. for 1) by using 'locate' (if installed) or 'find':

# find / -name libc.so.6

should point you to /lib64/libc.so.6 & maybe /lib/libc.so.6 ; on a 64 bits system you care for the first, so for 2):

# rpm -q -f /lib64/libc.so.6

on one of my systems it returns "glibc-2.5-42.el5_4.2"

so you would need a newer glibc package (& all the associated development packages) for your distribution. Same for all the other files. Unfortunately, most of them are from the base system, so you may be better off upgrading the entire distibution.

if a file is completely missing (you may not have the NUMA stuff by default, for instance), then I would suggest looking for it on "http://rpm.pbone.net/" to find the exact package to install.

HTH

Imagen de lystor

libc.so.* are provided by glibc-2.5-58.el5_6.3.x86_64.rpm
You can use Linux Packages Search (pkgs.org) to resolve other dependencies.

Inicie sesión para dejar un comentario.