Intel(R) VTune(TM) Amplifier XE installed on the MTL

Intel(R) VTune(TM) Amplifier XE installed on the MTL

To get started using Intel VTune Amplifier XE 2011:
- Add thedirectoy bin64 (or bin32) located in
/opt/intel/vtune_amplifier_xe_2011 to your PATH environment variable.
To start the graphical user interface: amplxe-gui
To use the command-line interface: amplxe-cl
- To view a table of getting started documents:
/opt/intel/vtune_amplifier_xe_2011/documentation/en/documentation_amplifier.htm

publicaciones de 7 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Hi,

I am running the command line interface of Vtune Amplifier.
I have no problems running hotspot orother user-mode analysis, but when I try to run lightweight-hotspots (which is based on hardware event-based sampling collection) I get two errors:

The first one is probably due to insufficient permissions (need to be added to the vtune user-group? If so please add me, my username is feng-s03) and says:

  • Fatal error: Problem accessing the sample driver (etc..)

The second one says:

  • Fatal error: Invalid value for comparison: $PMU==nhm. Null type context values can only be compared with 'NULL'. Check context value spelling.

Thank you!

I believe we have now fixed both these issues - thanks impart to a previousVtune Amplifier forum posting, that indicated that drivers needed to be built and installed.

Anyway completing some initial testing on the command line lightweight-hotspots EBS the following now appears to function and generate output
$ /opt/intel/vtune_amplifier_xe_2011/bin64/amplxe-cl -collect lightweight-hotspots -duration 3

Let us know if you still experience problems.

I had the same problem. But I use "root" to do lightweight-hotspots. This problem will not exist.

the drivers need to be restarted at Intel MTL as of 3/17/2012
i am getting "Problem accessing the sampling driver. The driver may need to be (re)started" error code -87.
check sbin/lsmod | grep sep3 and found nothing.
please help.

The underlying problem is that thereappears to beno VTune applicabledriver for the current RHEL 5.4 kernel version: 2.6.18-194.11.4.el5

I'm sorry, but I don't expect aresolutionin the near future.

Is it installed on MTL any tool to do hardware event-based sampling and analysis of applications? With VTune, it seems that it is not yet possible.

Deje un comentario

Por favor inicie sesión para agregar un comentario. ¿No es socio? Únase ya