IXP4XX Intel Access Library 3.0 bugs

IXP4XX Intel Access Library 3.0 bugs

Hi all,

I don't know where I can report IXP4XX Intel Access Library 3.0 (IAL3.0) bugs, so I post them here hoping to get some support. Here goes...

ATM access library Tx queue low/empty stuck interrupt.
OS: Linux
Processor: IXP435
description:
With ethernet driver and ATM driver both loaded, the ATM Tx queue low/empty interrupt triggers continuously after the first ATM cell is sent and there is nothing left to send. This stuck interrupt is causing the CPU to lockup. There's no interrupt before the first cell is sent. My ATM driver is working with IAL2.4, and on IAL3.0, all the ATM access library initialization functions returned success, so I don't think the bug lies in my ATM driver.

Ethernet driver high latency.
OS: Linux
Processor: IXP435
description:
With IAL3.0 and the corresponding Intel ethernet driver, I'm getting ping time of 10ms, but with the same hardware running IAL2.4 and corresponding Intel ethernet driver, I was getting ping time of ~1ms.

Does anyone know how to fix or workaround for these problems? Any input appreciated. Thanks for your help in advance.

Cheers,
-JA-

publicaciones de 2 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

If you are looking for IXP product support please contact your local distributor,the general support web page http://www.intel.com/support/, or submit a request via the Intel technical support page: http://supportmail.intel.com.

-Thai

Inicie sesión para dejar un comentario.