How to set -gcc-name=(dir) option?

How to set -gcc-name=(dir) option?

I'm wondering how to set -gcc-name= option, because I have a difficulty in gcc-4.1.0. On my system two versions of gcc's are installed (3.4.4 and 4.1.0) and I want to tell icc/icpc to use gcc-3.4.4's include files and libraries, though 4.1.0 is default.

in icpc.cfg I set

-long_double
-DTRUE=1
-DFALSE=0
-cxxlib-gcc
-gcc-name=/usr/i686-pc-linux-gnu/gcc-bin/3.4.4/

and actually in /usr/i686-pc-linux-gnu-gcc-bin/3.4.4/, there are g++,c++ etc. However icpc says:

if icpc -DHAVE_CONFIG_H -I. -I. -I.. -fPIC -DPIC -I../lib -I../api -I../db -I../client -I../tools -I../sched -pthread -fPIC -DPIC -I../lib -I../api -I../db -I../client -I../tools -I../sched -pthread -sox -xW -O3 -fp-model fast -no-prec-div -no-prec-sqrt -ipo -I/usr/include -I/usr/include/openssl -pthread -MT boinc_api.o -MD -MP -MF ".deps/boinc_api.Tpo" -c -o boinc_api.o boinc_api.C;
then mv -f ".deps/boinc_api.Tpo" ".deps/boinc_api.Po"; else rm -f ".deps/boinc_api.Tpo"; exit 1; fi
icpc: error: could not find directory in which /usr/i686-pc-linux-gnu/gcc-bin/3.4.4/ resides

How should I set -gcc-name= option? In the manual, -gcc-name= option is given the directory, however guessing from the error message "could not find directory in which xxxx resides", it seems to say "xxxx" resides somewhere and icpc finds it... strange..

So will anyone tell me how to set proper gcc/g++ to icc?

1 envío / 0 nuevos
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.