error: FPA instructions, whereas .//SigGen uses VFP instructions

error: FPA instructions, whereas .//SigGen uses VFP instructions

Myboard is sitsang with Xscale , I want to use the IPP 4.0, can I use arm-linux-gcc 3.2.1, because the other part of my program is combiled to the share library(.so) by it. I have listened that recommanded to use arm-linux-gcc 2.95 on IPP 3.0, and other combiler which I was forgotten for 4.0, but I really don't want to recombile all the library I use. What can I do?

publicaciones de 2 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Dear Customer,

What I recommend is to use Intel IPP v4.1, and you may check our compiler support for Linux* on Intel PCA processors:
I) forIntel PXA25x and PXA26x Processors:

Development tools:
(1) xscale_le-gcc (GCC) 3.2.1 20020930 (MontaVista), glibc 2.2.5 and binutils 2.12.1.(2) arm-linux-gcc (GCC) 3.3.2, glibc 2.3.2 and binutils 2.14.90.0.7 20031029.

II) for Intel PXA27X processors

Development tools:
(1) iwmmxt_le-gcc 3.3 (MontaVista), glibc 2.3.2 and binutils 2.14 20030612.
(2) arm-linux-gcc (GCC) 3.3.2, glibc 2.3.2 and binutils 2.14.90.0.7 20031029.

For more details, please check IPP release notes at:

http://www.intel.com/software/products/ipp/relnotes.htm

Hope it helps.

Thanks,
Ying S
Intel IPP Support

Inicie sesión para dejar un comentario.