Redhat8.0 or glibc>2.2.5

Redhat8.0 or glibc>2.2.5

Hi,

Apparently glibc2.2.5 is the latest supported by icc/ifc, etc, according to, for example:

http://www.intel.com/support/performancetools/c/linux/redhat80.htm

What plans are there to support 2.2.93 or 2.3 of some flavor?

Thanks,
Jon

publicaciones de 6 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Jon - It is in the 2003 plans.

Cheers,
Ganesh

To which extent is 2.2.93 unsupported? Are there known issues, or is it just a warning that the setup has not been thoroughly tested?

I use glibc-2.3.1 on a system without a distro and icc seems to work fine. I would also be very interested if there are any known issues.

--
Markus

An update to the 7.0 compiler will be available in the short term that will provide support for glibc 2.2.93 on IA-32.

The compiler is validated on the glibc/kernel combinations that we list as supported for a given relase. This includes running the compiler test suite to test functionality in all parts of the compiler. Other glibc/kernel combos are not tested. Although many users report success with other combinations, there might be problems that are not obvious.

The compiler interacts very closely with system libraries & kernel, and it's possible for certain applications to function correctly on unsupported systems, whereas others will not on, depending on what the application interacts with.

Regards,
John

When will be the update that support glibc 2.2.93 available approximately?

Inicie sesión para dejar un comentario.