Intel Composer XE 2013 Installations issues

Intel Composer XE 2013 Installations issues

Hi!

I've downloaded a non-commersial version of Composer XE 2013 for Intel64 and tried to install it on Debian 6.0 system. It is declared as supported. The installation though can't be called successful.

From the very beginning after launching install.sh script I've got several errors "sh: Syntax error: Bad fd number". After that several errors nothing seems to go wrong during installation but I end up with empty compilervars.sh file, so installation is pretty much unusable.

This is the installation log found in /var/log/intel_studio_rpm_install.log:

Fri Sep 07 21:18:57: RUN: <:>.
Fri Sep 07 21:18:57: ret: 0.
-+ Logging in shell wrapper is started with LOG=/var/log/intel_studio_rpm_install.log +-
Fri Sep 07 21:18:57: MAIN: Installation mode is equal to RPM.
Fri Sep 07 21:18:57: Cannot get shared lock on RPM Database
Fri Sep 07 21:18:57: INSTALL_PRODUCT:INFO Installing RPM package /home/dmitrmax/Downloads/cpp_studio_xe_2013_intel64/./rpm/intel-ipsc-2.0p-021.noarch.rpm -ivh --ignorearch --oldpackage --nodeps --prefix /opt/intel/parallel_studio_xe_2013
Fri Sep 07 21:18:57: Install rpm - /home/dmitrmax/Downloads/cpp_studio_xe_2013_intel64/./rpm/intel-ipsc-2.0p-021.noarch.rpm
Fri Sep 07 21:18:57: Options are: '-ivh --ignorearch --oldpackage --nodeps'.
Fri Sep 07 21:18:57: Cannot get shared lock on RPM Database
Fri Sep 07 21:18:57: Cannot get shared lock on RPM Database
Fri Sep 07 21:18:57: MAKE_TEMP_FILE.
Fri Sep 07 21:18:57: RUN: <mktemp>, <-q>, </tmp/install.XXXXXXXX>.
Fri Sep 07 21:18:57: ret: 0.
Fri Sep 07 21:18:57: ret: </tmp/install.KZHksJm2>.
Fri Sep 07 21:18:57: Using rpm install with relocation to '/opt/intel/parallel_studio_xe_2013'
Fri Sep 07 21:18:57: '/home/dmitrmax/Downloads/cpp_studio_xe_2013_intel64/./rpm/intel-ipsc-2.0p-021.noarch.rpm' installed
Fri Sep 07 21:18:57: MAIN: Installation has been finished successfully.

publicaciones de 18 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Normally, you need to run as root (e.g. by sudo) for permission to acquire a lock on rpm database, so as to modify it during rpm install. If some other rpm installation is hung, it may have a lock which it doesn't yield.
The install.sh script which comes with the compiler will ask you for root password. There is a non-root installation option to select and install in a directory owned by you.

Hi Tim!

Sure, I've tried it both ways - running as root or acquiring root permissions via sudo in installer. Both ways end up as I said in original post. Furthermore, I've tried it on two machines running Debian 6.0 and the result is the same.

I suspect that link_install.sh script is guilty for that. Later I'll try to replace this script in the distributive with an empty one and reinstall.

Cita:

dmitrmax escribió:
Later I'll try to replace this script in the distributive with an empty one and reinstall.

There are also issues with uninstall script. It simply doesn't work on Debian (and I guess Ubuntu too) with the following diagnostics:
ERROR: Cannot get shared lock on RPM database.

This is because uninstall.sh checks for RPM lock by issueing command "rpm -q rpm" - it looks if the rpm package is installed. But sinse RPM database on Debian contains no rpm package (only Intel's packages are in DB on the clean system), this command fails. You should use simple "rpm -qa" to test if shared lock can be acquired. After I've patched the script, I managed to uninstall the Composer 2013.

Shame on your testers ;-)

Ok, Tim!

I figured out the reason. It is not link_install.sh script. It is a bug in the post installation script of package intel-compilerpro-common-079-13.0-0.noarch.rpm.

There is a line:

cp "$INSTALL_FILE" "$INSTALL_FILE.old" &>/dev/null

This runs the copy process in the background due to & specified at the end of the command. This triggers the race condition because next commands operate with $INSTALL_FILE.old which can run before the copy process finishes. That is the cause of zero-length files.

There are several more places which execute processes in the background in post-install script - generally it is a bad idea.

So... when we can expect updated version of installer which runs on Debian without these issues?

I am experiencing the same issue on Ubuntu 12.04. When I install Intel Fortran Composer XE 2013 on root, using sudo, I get no complaints during the install process. However, when the script completes, all of the compilervars.sh (and similar) files are zero-length. I tried to install the 2011 edition also, and I just ignored the complaint about the unsupported OS. Once again, after the install, I have zero-length files under the /opt/intel directory.

Is there a fix for this issue, or at least a work around?

Same issue here, on kubuntu 12.04, including the several "sh: Syntax error: Bad fd number" messages at the begining of installation.

Imagen de James Tullos (Intel)

For Ubuntu* 12.04 (and possibly Debian*), this is a problem with the default shell. Set /bin/sh to link to /bin/bash and try again.

Sincerely,
James Tullos
Technical Consulting Engineer
Intel® Cluster Tools

Thanks James Tullos. However, I have another problem now: Because the uninstall script didn't work either, I manually removed the files from /opt/intel. Now, when I try to install again (using bash instead of dash), I get the following error:

--------------------------------------------------------------------------------
The Intel(R) Parallel Studio XE 2013 for Linux* is already installed.

If you want to reinstall the Intel(R) Parallel Studio XE 2013 for Linux*
please uninstall current version and run install script again.
--------------------------------------------------------------------------------

How can I unsinstall it, when all files have been deleted?

By the way, since Ubuntu 12.04 is supported according to the release notes, the installation script should work out of the box, without any tampering of the default system shell, dash.

Thanks,

Alexandros

Cita:

alexandross escribió:

How can I unsinstall it, when all files have been deleted?


Try to delete RPM database in /root/.rpmdb. And the next time you want to uninstall, patch the uninstall.sh script as I said above.

Thanks Max, this is what I did, and the problem was fixed:

sudo su
for i in `rpm -qa | grep intel` ; do rpm -e $i ; done

Like you said, the RPM database contained only the intel packages, so I guess it would be safe to just delete the database as you suggested. Hopefully the intel guys will provide real Debian-oriented installation scripts soon.

Can somebody confirm that setting /bin/sh to link to /bin/bash works on a fresh Ubuntu 12.04 ? I am quite a newbie and would not be very good at patching lots of stuff...

Thanks in advance.

Cita:

dan0112 escribió:

Can somebody confirm that setting /bin/sh to link to /bin/bash works on a fresh Ubuntu 12.04 ? I am quite a newbie and would not be very good at patching lots of stuff...

Just run:


$ sudo rm /bin/sh

$ sudo ln -s /bin/bash /bin/sh

Run new terminal and install the Composer XE 2013.

After installation revert it back:


$ sudo rm /bin/sh

$ sudo ln -s /bin/dash /bin/sh

Imagen de Michal Kvasnicka

Intel Parallel Studio XE 2013 for Linux has apparently a lot of bugs at install and uninstall scripts. So, when we can expect patched version? The current version is not possible to install on production server without above mentioned steps!

Thanks in advance for answer from Intel staff...

Max,

thanks a lot, worked perfectly on a fresh Kubuntu 12.04 64 bit.

Hye to all.

Im experiencing the same problem as alexandross -- getting stuck in reinstalling Intel(R) Composer XE 2013. I am new to Linux, so Im a bit worried about deleting RPM database. Im currently on Red Hat 4.6.0-9 and I couldn't find the .rpmdb file as stated above. I would be very grateful if community members could suggest me how to proceed with this.

Thanks so much

Ika

zibrahim,
The .deb based distributives (Debian and *buntu) are discussed here. Red Hat is .rpm based distro. But IIRC if you read the release notes to XE 2013 you may find that RedHat 4 is no more supported. So you need to migrate to the 5th or 6th version.

Imagen de shin

Hi all

quote
thanks a lot, worked perfectly on a fresh Kubuntu 12.04 64 bit.

ive runinng it both in windows 64bit and Kubuntu 12.04 64 bit. and i have no problem.

shin

Inicie sesión para dejar un comentario.