Linux Fedora 17 64bits

Linux Fedora 17 64bits

I have installed C++ Compiler 11.1.080  and without problems, but There is not all the libraries in the bin folder and compiler doesn't work. After this It happen the same with fortran.

Do you know anything about it? It's possiblle to work Fedora 17 with this intel compilers.

publicaciones de 7 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Hi Jofre J.,

Maybe someone here can help you to get it to work, but Fedora 17* isn't supported with that version. For Fedora 17 support, you should use Intel(R) Composer XE 2013.

Brandon Hewitt Technical Consulting Engineer For 1:1 technical support: http://premier.intel.com Software Product Support info: http://www.intel.com/software/support

I have installed Intel(R) Composer XE 2013, how can i know if it is ok? The installation has been ok.

I am trying to install Intel non-commercial C compiler on Fedora 17. First I installed Intel® C++ Composer XE 2013 for Linux 

in the Compilers and Libraries section. It downloads by default the latest update. But while installing I get error message on Step 1 of 7.

Missing optional prerequisites
-- Unsupported OS

The Details says it supports Fedora 18 and 19. So can anyone suggest an appropriate Compiler version?

But under the product suites:

Intel® C++ Studio XE 2013 for Linux

installs absolutely with no error message.

Hence after all this I can't invoke the icc. Can anyone help?

Thanks, PD.

The above issue is still there. With the error as above I completed the installation of the Compiler (Intel® C++ Composer XE 2013 for Linux ). 

Then ran the command 

source /opt/intel/composer_xe_2013_sp1.3.174/bin/iccvars.sh

Almost followed whatever it is in the link

https://software.intel.com/en-us/articles/using-intelr-compilers-for-lin...

But now invoking icc I get the following error message: ld: cannot find -lstdc++

Now I see libstdc++ is installed like invoking the command

ldconfig -p | grep libstdc++  the output is

libstdc++.so.6 (libc6,x86-64) => /lib/libstdc++.so.6
        libstdc++.so.6 (libc6,x86-64) => /lib64/libstdc++.so.6
        libstdc++.so.5 (libc6,x86-64) => /lib64/libstdc++.so.5

I created symbolic link of libstdc++.so.6 to the folder /usr/lib/, /lib/, /opt/intel/composer_xe_2013_sp1.3.174/bin/ 

but I get the same compilation error: ld: cannot find -lstdc++

I am still a novice on all this. So can anyone help me out.

 

 

The command icpc includes specific references to search libstdc++ (normally, using the paths inherited from the g++ you have active).  As icc is a C compiler, it doesn't include C++ library paths by default in its creation of an ld script.

If you built a .c source file using gcc or icc, it wouldn't find STL headers nor use mangling conventions which would enable it to call functions in libstdc++.

The distinction between icc and icpc for the most part mirrors that between gcc and g++.

Thanks Tim. Invoking g++ gave the error message: bash: g++: command not found...

So installing g++ by: yum install gcc-c++

solved my problem. Thanks again. PD.

Deje un comentario

Por favor inicie sesión para agregar un comentario. ¿No es socio? Únase ya