Cannot rebuild GPL gear for KNC_gold_update_1-2.1.4982-15-suse-11.2

Cannot rebuild GPL gear for KNC_gold_update_1-2.1.4982-15-suse-11.2

It works fine untill it starts building the manpages then I get

FAILED: /root/KNC_gold_update_1-2.1.4982-15-suse-11.2/gpl/documentation/man/scif_open.txt: line 40: missing endif::scif_user[]
a2x: failed: asciidoc --doctype=manpage -a "scif_user" -d manpage -b docbook "scif_open.txt"

It seems that the ascidoc package with SUSE 11 SP2 doesn't like something. I've not used asciidoc before so I have no idea where to start hitting it to make it work.

publicaciones de 5 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

According to my reading of the asciidoc manual, the .txt file is correct and no #endif is required. I do not have a2x installed on the machine I use at the moment but will try to do that. In the meantime, if anyone else has done this rebuild, perhaps they could share their experience. 

That is what I could determine as well.. Which version of asciidoc was used to build the original RPM's possibly I have a version skew issue.

Also adding an endif::scif_user[] block causes a pile of other errors.. 

Is there a way I can rebuild without the man pages.. because we really don't need them. 


I'm still unable to rebuild. Which is annoying as I can't use the damn things at the moment because of it... 

Just FYI - when I tried building the man pages everything worked. We are now several releases past KNC_gold_update_1-2.1.4982-15 and I haven't heard of any more problems.

Inicie sesión para dejar un comentario.