Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*)

Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*)

Hi,

I am trying to use IntelVtune in a Nehalem system and for all types of data collection i get the following error:

amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.

The system i am using ths is  a 2*6core Intel Xeon E5645. I have disabled SMT. The operating system is Linux kernel 2.6.35

Please let me know if you know anything about this error.

Thanks,

Raoofeh

publicaciones de 16 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Finally found the help topic mentioned in the error. problem solved !

Hi,

    I have the same problem with you,how did you solve it?  

Thanks

Quote:

ZJ Z. wrote:

Hi,

    I have the same problem with you,how did you solve it?  

Thanks

1. First at all, you need to use root privilege user to install the tool. The installer will try to build vtune drivers for your system.

2. After installing the tool, you have to check if divers have been installed in the system. For example, "lsmod | grep sep3", "lsmod | grep pax", "lsmod | grep vtsspp".

3. If you haven't successfully built drivers during installing the product, go vtune_amplifier_xe_2013/sepdk/src, run such as build-driver, and ensure that you have kernel source which is corresponding to running OS. Then you can run such as insmod-sep, maybe you can specify new vtune group - for example, "insmod-sep -g vtune-group" to create a new group. If you don't use this option, the program will create default group named "vtune".

4. You can log on as none-root user when running VTune, but your user account should be in "vtune" group, for example. 

Thank you for your explanation, I have solved the problem.

How have you solved the problem? Im facing the same problem here. Already did waht Peter told, my modules are ok.

Tks

Juliano Marcos Martins

Quote:

Juliano M. wrote:

How have you solved the problem? Im facing the same problem here. Already did waht Peter told, my modules are ok.

Tks

The key points are :

1. Ensure that you have removed all existing vtune drivers (sep3, pax, vtsspp, apwr3) before installing new drivers.

2. If you want to create a new vtune group - if group does exist, use "groupdel" to remove it first, so it will be created by the insmod-sep. And don't forget to add your user account to this group.

I don't know what else I can help unless you provide more info.

Hey guys,

I am new to Vtune and was using it on a Windows Server 2012 to profile a driver. I am profiling the driver by running IOmeter on Vtune and source and symbols of my driver.

a. I am geting an error saying :Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*)

b. The function names are not visible(They are being displayed as function@123 instruction level) though I have loaded the symbols and my source code 

any suggestions??

@Tejas

I gave a suggestion for how to check for pdb symbols problem.Check the other thread when you have also asked the same question.

I recently received an e-mail from Intel Registration Center suggesting I upgrade to a new version of Vtune. I did so, and immediately began having the sort of problems described in this thread. I tried reverting to the older installation, but I still got the same sort of issues. I tried rebuilding the drivers, which then required me to run various configuration scripts on my kernel source. However, that did not fix the problem. When I try to install the new drivers, I get error messages like this, for pax;

SNB-cblab04:/opt/intel/vtune_amplifier_xe_2013/sepdk/src/pax # ./insmod-pax
Executing: insmod ./pax-x32_64-3.0.76-0.11-defaultsmp.ko
insmod: error inserting './pax-x32_64-3.0.76-0.11-defaultsmp.ko': -1 Invalid module format

Error:  pax driver failed to load!

You may need to build pax driver for your kernel.
Please see the pax driver README for instructions.

I ran the demsg command, and found the following;

[3456923.246817] pax: version magic '3.0.101 SMP mod_unload ' should be '3.0.76-0.11-default SMP mod_unload modversions '

3.1.101 is the version number on my Linux kernel source, and I am thinking the problem may be related to the fact that since I first installed Vtune, I have upgraded from SLES 11.2 to SLES 11.3.
 

 

Hi Jerome B.:

If the kernel is updated, the sep and vtsspp drivers must be rebuild against the updated kernel sources/headers.  If you've installed the kernel-devel* RPMs, it should be as simple as executing the ./build-driver script (pressing Enter at each prompt to select the default) and then executing ./insmod-sep3, all as 'root'.  (You might need to specify -r to "reload", if one or more of the drivers is loaded - use 'lsmod' to view loaded kernel modules.)

Regards, MrAnderson

Update: It appears that SLES 11.3 delivers a more recent version of the kernel sources than the one I was running. Therefore, when I rebuilt the kernel, the version reported by uname -r did not match the source version. Rebooting the system fixed this, and Vtune -- er, amplxe -- is working again.

Hi,
  I am new to VTune Amplifier and I developing an Android application on Intel Atom processor. When try to run profiling I get the following error
  amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.
  
  I am running VTune Amplifier with eclipse on my windows.
  I was not able to interrupt previous comments by Mr Wang for re installing the drivers.
  Can somebody please elaborate to resolve the issue.
NOTE: I am more of a windows guy, steps friendly with windows will be of great help to me.

Regards
Harrison  

Quote:

Harrisson M. wrote:

Hi,

  I am new to VTune Amplifier and I developing an Android application on Intel Atom processor. When try to run profiling I get the following error

  amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.

  

  I am running VTune Amplifier with eclipse on my windows.

  I was not able to interrupt previous comments by Mr Wang for re installing the drivers.

  Can somebody please elaborate to resolve the issue.

NOTE: I am more of a windows guy, steps friendly with windows will be of great help to me.

Regards

Harrison  

I'm not the expert working on Android system and no such device on hand, based on error message - I suspect you logged on non-root user. If so, your user account should be in driver group. You may raise this issue to Intel system studio forum, where many people work on Android.  

Quote:

Harrisson M. wrote:

  I am new to VTune Amplifier and I developing an Android application on Intel Atom processor. When try to run profiling I get the following error
  amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.

Hi Harrisson,

as already indicated the Intel® System Studio Forum would be a better option for this question :-). I copied my answer below from your same question on Stackoverflow:

The error message indicates that you missing the required drivers for an Advanced Hotspotsanalysis. These drivers are required as the analysis is using a dedicated hardware inside the CPU called Performance Monitoring Unit (PMU). On production devices you can buy in a store it's unlikely to have these drivers preinstalled.

You have the following options to workaround this:

  1. Use the Basic Hotspots analysis. This works without special drivers on any Intel based Android device. If your device is not rooted you also need to configure the application in debug mode. There is an article available: Using Intel® VTune™ Amplifier 2014 for Systems on non-rooted Android* devices.
  2. If you are using a "Dell Venue 8" you can turn this device into a developer device. This basically means you flash it with a special firmware that contains the drivers for VTune and is also rooted by default. With such a configuration you can also do an Advanced Hotspots Analysis. Instructions can be found here: How to use Intel® VTune™ Amplifier 2014 for Systems on a Dell Venue 8
  3. You rebuild the required drivers for the Advanced Hotspots Analysis by yourself. This is only possible if you have a device with an open boot loader and the sources to rebuild the kernel. In general I wouldn't recommend this option until you are working for a device manufacture. If you are interested in this option let me know and I will add an explanation about it.

Out of curiosity: What is the device you are using? What kind of application are you trying to profile?

Thanks,
Alex

I am consistently getting an error showing in Event Manager for vtss service failed to start due to the following error:
%%4294967290

The detail is as follows:

+ System

  - Provider

   [ Name]  Service Control Manager
   [ Guid]  {555908d1-a6d7-4695-8e1e-26931d2012f4}
   [ EventSourceName]  Service Control Manager
 
  - EventID 7000

   [ Qualifiers]  49152
 
   Version 0
 
   Level 2
 
   Task 0
 
   Opcode 0
 
   Keywords 0x8080000000000000
 
  - TimeCreated

   [ SystemTime]  2015-03-29T04:24:16.958770200Z
 
   EventRecordID 3852
 
   Correlation
 
  - Execution

   [ ProcessID]  720
   [ ThreadID]  6020
 
   Channel System
 
   Computer Kongen
 
   Security
 

- EventData

  param1 vtss
  param2 %%4294967290
   76007400730073000000

--------------------------------------------------------------------------------

Binary data:

In Words

0000: 00740076 00730073 0000  

In Bytes

0000: 76 00 74 00 73 00 73 00   v.t.s.s.
0008: 00 00                     ..

 

I have uninstalled VTune and then found vtss.sys and deleted it.  I then re-installed, but immediately got the same error again. 

I am on a Windows 8.1 (64Bit) Professional System and using Intel Parallel Studio Professional 2015 Update 2

abt

Inicie sesión para dejar un comentario.