Micctl not seeing card

Micctl not seeing card

All,

Having trouble getting the mic drivers working.

Running CentOS 6.4 with the 2.6.32-358.6.2.el6.x86_64 kernel (this is because we use Lustre as well).

I am able to compile and install the kernel drivers and I can load the mic module:

[root@compute-8-35 ~]# lsmod|grep mic
mic 581887 0

But:

[root@compute-8-35 ~]# /opt/intel/mic/bin/micinfo
MicInfo Utility Log

Created Tue Aug 20 12:46:11 2013

System Info
HOST OS : Linux
OS Version : 2.6.32-358.6.2.el6.x86_64
Driver Version : 6720-16
MPSS Version : 2.1.6720-16
Host Physical Memory : 132133 MB
[root@compute-8-35 ~]#

And 

[root@compute-8-35 ~]# /opt/intel/mic/bin/miccheck

miccheck 2.1.6720-16, created 14:00:54 Jul 11 2013
Copyright 2011-2013 Intel Corporation All rights reserved

Test 1 Ensure installation matches manifest : OK
Test 2 Ensure host driver is loaded : OK
Test 3 Ensure driver matches manifest : OK
Test 3> Error 0x2: No Intel(R) Xeon Phi(TM) Coprocessors in this system

Test 3> Error 0x2: No Intel(R) Xeon Phi(TM) Coprocessors in this system

Test 4 Detect all listed devices : SKIPPED
Test 4> Prerequisite 'Initialize the API' failed:
Test 4> Failed to initialize the API
Status: Error 0x2: No Intel(R) Xeon Phi(TM) Coprocessors in this system

I see a ton of stuff for the two cards under 'lspci' is there anything in particular to be looking for there?

Brian Andrus

 

 

publicaciones de 3 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Hi Brian, I was looking at older posts and saw that no one replied to you ...

A common problem is not having "large BAR" support enabled in the systems BIOS. You usually see this as an option under "advanced settings"  related to the PCI bus. It's often referred to as "Above 4G decoding"  Look for that and make sure it's enabled.

If you have that enabled and the cards are still not seen then look near the top of the lspci -v output for one of your cards ... if you see something like

          Memory at <ignored> (64-bit, prefetchable)  [size=8G]

then your motherboard is probably not going to support Phi.

Best wishes -Don

Don,

Thanks. It turned out I needed to flash the MIC cards and then they showed up as expected.

Brian

Inicie sesión para dejar un comentario.