GUI Problems with Windows 7

GUI Problems with Windows 7

I have an Intel Visual Fortran 11.1 program that generates user interface GUIs.  The program works properly on some Windows 7 machines and on other Windows 7 machines it does not work properly.  When executed, the initial program GUI doesn't pop up.  Reviewing in Task Manager, I can see that the program is running, but there is no indication on the desktop that it is running.  I tried running it in other compatibility modes, but that didn't solve the problem. 

Why would the code run fine on some Windows 7 machines and not on others?  Are the other Windows 7 machines missing a driver?

publicaciones de 7 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

You need to see if UI thread is running and waiting on user input.You can use Process Explorer and look at threads info next search for thread which is executing message pump loop it will be probably UI thread.

This is a qwuickwin application.  I read the sugested forum topic 293107.  I recompiled with the forum posted ifqwin.lib for x86.  Still no initial window being displayed.  Still can see the programing running in Task Manager.

 

  >>>Still can see the programing running in Task Manager.>>>

Seeing process running in Task Manager will not help you understand why there is a problem.Can you follow my advise and at least post the output of Process Explorer?

Here is the Thread from Process Explorer

From the Thread:

Test_Program_(2013_11_18)_Beta.exe+0x11b25e

 

In the Stack is:

Test_Program_ (20131118)_Beta.exe+0x1448e7

Test_Program_(2013_11_18)_Beta.exe+0xbc5e8

Test_Program_(2013_11_18)_Beta.exe+0x1448e7

How many threads does your program have?You posted probably not complete call stack I cannot see any thread creating Windows functions at the bottom of the stack?

Can you post full call stack from every thread which was created by your process?

Deje un comentario

Por favor inicie sesión para agregar un comentario. ¿No es socio? Únase ya