Icl: warning #10316: option '/Qgen-matmul' not supported at optimization levels less than '/O2'

Icl: warning #10316: option '/Qgen-matmul' not supported at optimization levels less than '/O2'

A small inconsistency with a warning message #10316 is detected and more details will be provided.

publicaciones de 5 / 0 nuevos
Último envío
Para obtener más información sobre las optimizaciones del compilador, consulte el aviso sobre la optimización.

Here are details:

A small inconsistency with a warning message #10316 is detected and consider two cases with command line options:

.../Od /Qopt-matmul...
or
.../O1 /Qopt-matmul...

If /Qopt-matmul is used and optimization levels are /Od or /O1, then the following warning is displayed:
...
Icl: warning #10316: option '/Qgen-matmul' not supported at optimization levels less than '/O2'
...
however, a correct warning message should be:
...
Icl: warning #10316: option '/Qopt-matmul' not supported at optimization levels less than '/O2'
...
It is clear this is a legacy issue since option /Qgen-matmul is no longer supported and was changed to /Qopt-matmul some time ago.

Best Reply

Hi Sergey,

I'm entering this issue to our problem tracking database. Thank you for your report.

Thanks.

In essence a modification is very simple, that is, just change a string from gen-matmul to opt-matmul and I understand that lost of verifications need to be done to check that nothing else is affected in Intel C++ compiler.

Thanks, Feilong.

Hi Sergey,

I was informed that this issue has been fixed in 15.0 compiler.  FYI.

Thanks.

Inicie sesión para dejar un comentario.