Fatal compilation error: Out of memory

Fatal compilation error: Out of memory

Portrait de angel-soria

I have a solution that compiles ok with VS2008 + IntelC++ v11.1.
I port this solution to VS2010 + Intel ComposerXE Update11, and compiles fine in debug with VS compiler. But when I try to compile in Release mode with Intel compiler, one of the projects fail with out of memory Error. ( RAM usage reaches 7 Gb of RAM then fail ) ( I have 12Gb RAM Windows 7 Pro x64 )
ResourceCompile:
Todas las salidas estn actualizadas.
Link:
C:\\Program Files (x86)\\Intel\\Composer XE 2011 SP1\\bin\\ia32\\xilink.exe ...........

Fatal compilation error: Out of memory asking for 2101256.
1>xilink : error #10014: problem during multi-file optimization compilation (code 1)
1>xilink : error #10014: problem during multi-file optimization compilation (code 1)

If I set off Interprocedural Optimization with /qnoipo then:

1>wtabla.obj : warning LNK4229: se encontr la directiva '/Intel compiler non-linkable IL object file' no vlida; se omiti
.......
1>wtabla2.obj : warning LNK4229: se encontr la directiva '/Intel compiler non-linkable IL object file' no vlida; se omiti
1>LINK : error LNK2001: smbolo externo _WinMainCRTStartup sin resolver
1>D:\\Angel\\VirtualRT\\v_6.0.3\\fuentes\\..\\PCRT.exe : fatal error LNK1120: 1 externos sin resolver
1>
1>ERROR al compilar.

Any idea?
Thanks.

4 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.
Portrait de Tim Prince

If you want to try removing IPO from your project, you will need to clean out the IPO objects. If I understand the mixture of English and Spanish in the message, you have an IPO object file left over from your earlier attempts.
It's not at all unusual to build entirely without IPO, for example, if you wish to combine CL and ICL generated objects.
For your IPO out of memory problem, if you are using the current (12.1 update 5) or beta (13.0 update 2) and can't resolve it by the ipo-separate options, you are welcome to submit the case in a problem report on your premier.intel.com support account.

Portrait de hubert-haberstock (Intel)

Did you specify /qnoipo as Linker option?
IPO needs to be switched off in the compiler as well as in the linker options settings:
Compiler:
Project Properties > Configuration Properties > C/C++ > Optimization [Intel c++] > Interprocedural Optimization: No
Linker:
Project Properties > Configuration Properties > Linker > Optimization [Intel c++] > Interprocedural Optimization: No (/qnoipo)

Portrait de angel-soria

Sorry for the delay in replying...
I could compile without IPO. I will try with IPO on the next Intel compiler version....
Thanks!

Connectez-vous pour laisser un commentaire.