Missing shared libraries *.so in ifc 7.0

Missing shared libraries *.so in ifc 7.0

Hi,

I'm trying to compile and link my code using ifc 7. The command is

ifc -r8 -ip -w95 -static-libcxa -fPIC -g -w90 -w -ldl -lgcc_eh -Wl,-rpath,/opt/intel/compiler70/ia32/lib -L/opt/intel/compiler70/ia32/lib -Wl,-rpath,/usr/lib -L/usr/lib -lintrins -lPEPCF90 -lIEPCF90 -lF90 -limf -lm -lirc -lcxa -lunwind -o a.out $(OBJS) ns_c.f90 $(libs)

I have already included the library path for the compiler libraries. It worked fine if I run it directly. However for big jobs, it's run in the background using bsub.

It then gives the error that the libraries files are not found such as libPEPCF90.so not found.

I tried using -static but it does not work. There's lots of undefined reference. Using i-static compiled ok but gives "Exec format error. Wrong Architecture" when run.

How can I solve the problem?

Thank you.

1 contribution / 0 nouveau(x)
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.