Cannot activate TLS communication

Cannot activate TLS communication

Hi All,

Using "Manageability Director Tool" version 7.0.11161.2

Whenever I try to enable TLS and "Set this profile on computers" get the following error message:
I'm using the "Sample Root" that you can generate with the tool.

I can communicate fine using HTTP to port 16992.

Ideas?

Thanks

Version: 7.0.11161.2

ERROR: System.ArgumentOutOfRangeException: Length cannot be less than zero.

Parameter name: length

at System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy)

at ManageabilityStack.CertificateOperations.GetPkcs1PrivateKeyFromCert(X509Certificate2 certificate)

at ManageabilityCommanderTool.EditTLSCertForm.newCertButton_Click(Object sender, EventArgs e)

at System.Windows.Forms.Control.OnClick(EventArgs e)

at System.Windows.Forms.Button.OnClick(EventArgs e)

at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ButtonBase.WndProc(Message& m)

at System.Windows.Forms.Button.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

4 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.
Portrait de Judy Hartley (Intel)

Hi primo2011,
Thanks for your post. Can you pleasegive us some more information? What AMT version is your system using? Did you enable TLS during configuration? The 7.0 SDKreference material states that TLS is disabled by default. I looked here: http://software.intel.com/sites/manageability/AMT_Implementation_and_Reference_Guide/DOCS/Implementation%20and%20Reference%20Guide/default.htm
and searched for TLS. Choosing the page called "Manual Setup and Configuration (from Release 6.0).

Please let me know if this helps and we will work on helping you further.

Cheers,
Judy

Hello Primo2011,

This looks like a bug with the 7.0.11161.2 code.I can seethis issue with the 7.0.11161.2 version, but when I roll back to the 6.1.x version, I do not see this issue.

I know Intel is planning the next release of the DTK tool. This will be addedand fixed in the next release. The sad part is that I do not know when the next release is, but rumor has it that it should happenin Q4. (Which we are in now)=)

Thank you for submitting this and brining attention to it.

Regards,
LM

Portrait de ylian-saint-hilaire (Intel)

If you get a chance, try out Manageability Director in the OpenMDTK and see if you get the same problem. If you do, let me know and I will fix it right away. Well, as fast as I can...

Ylian

Connectez-vous pour laisser un commentaire.