"Could not connect to remote machine 127.0.0.1." after " The Sampling Collector failed to collect data because the selected event(s) did not occur."

"Could not connect to remote machine 127.0.0.1." after " The Sampling Collector failed to collect data because the selected event(s) did not occur."

I wrote a script to measure the "MACHINE_CLEARS.MEM_ORDER" performance counter on a Nehaleme machine on my program with different parameters.

However, when the script goes, the first several runs gets good result. Then it comes to "The Sampling Collector failed to collect data because the selected event(s) did not occur".

After that, there will always be "Could not connect to remote machine 127.0.0.1" even if I run vtune for profiling other programs. The only way to solve it is to hard reboot. But if running the script several for several runs, it wil also come out "Could not connect to remote machine 127.0.0.1." after " The Sampling Collector failed to collect data because the selected event(s) did not occur."

Why is it?

Following is my script:

for D in 0
do
for G in 2 4 8 16 32 64 128 256 512 1024 2048 4096 8192 16384 32768 65536 131072 262144 524288 1048576 2097152 41943 04 8388608 16777216
do
echo ./aggregate -D /home/yeyang/inputgen -n 24 -r 1 -t 16 -d $D -g $G -c 10
vtl activity test_$D -d 10 -start-paused \\
-c sampling -o "-cal yes -ec \\
-en='MACHINE_CLEARS.MEM_ORDER' \\
" -app ./aggregate,"-D /home/yeyang/inputgen -n 24 -r 1 -t 16 -d $D -g $G -c >>Local/OUTPUT_THREAD16_ON_$D.t xt" run

done
done

8 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Hi,

"The Sampling Collector failed to collect data because the selected event(s) did not occur" usually means, VTune Performance can't recognize your processor.

1. Are you using latest product v9.1 Update 7?
2. What is your working processor?

Simply use "vtl query -lc" to know supported collectors in your system; use "vtl query -c sampling" tocheck if your favorite eventis supported in output.

Regards, Peter

This behavior has been observed in rare cases. A simpler workaround than rebooting is to simply unload (rmmod-vtune) and reload (insmod-vtune) the sampling driver.

If you would like us to investigate further, please submit an issue at Intel Premier Support.

Regards, MrAnderson

Sorry, but rmmod-vtune and insmod-vtune does not solve the proble, we still have "Could not connect to remote machine 127.0.0.1."

Thank you

1. We're using the latest version
2. THe processor is Intel Xeon CPU X5550 @ 2.67GHz

3. when we use the "vtl query -lc", both the sampling and call graph collectors are supported.

Thank you

1. We're using the latest version
2. THe processor is Intel Xeon CPU X5550 @ 2.67GHz

3. when we use the "vtl query -lc", both the sampling and call graph collectors are supported.

Please check if vtune driver has been loaded, "lsmod | grep vtune"

If not, please go to vtune_dir/vdk/src, and do
1. build-driver
2. insmod-vtune
3. install-boot-script --install

Ensure sampling collector can work by tyring simple command line - "vtl activity -c sampling -d 5 run".

Regards, Peter

Additional points are:

1. I mentioned to check if your using Event is in output of "vtl query -c sampling"
2. Can VTune Analyzer graphic interface (vtlec) run with your app?
3. Is it possible that was due to two long program's parameters?
4. Is it possible that was due to "-start-paused"? Where did you resume collector? Note that if call sequence was incorrect, such as paused-paused or resumed-resumed will cause vtune driver unstable. You need to reboot the system.

Regards, Peter

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui