MPIEXEC_SIGNAL_PROPAGATION or I_MPI_JOB_SIGNAL_PROPAGATION variable not taking effect

MPIEXEC_SIGNAL_PROPAGATION or I_MPI_JOB_SIGNAL_PROPAGATION variable not taking effect

Portrait de Amrita Mathuriya (Intel)

Hi,

I have installed signal handlers in my process for SIGINT signal. I want the following behavior - whenever I press Ctrl + c, mpiexec should pass this signal to individual processes and the user-defined signal handler should be called - which does the clean up process (to remove semaphore) and then finally kills the process.
I read in the reference manual that _MPI_JOB_SIGNAL_PROPAGATION environment variable is able to propagate SIGINT signal. However, even after passing this variable to mpiexec, the indiviual processes are getting killed by SIGKILL signal and not by SIGINT and as a result user defined signal handler is not being called to do the clean up process.

Urgent help is required.
Thanks in advance.

Amrita

2 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.
Portrait de fabien d.

Hi,

I have a similar problem. Does someone know how to fix this ?

I launch a job on 2 nodes with multiple mpi processes per node. I use kill -9 PID to kill one of the mpi processes on a node, all mpi processes defined on this node die. However the mpi processes on the second node to get kill...

I tried to use I_MPI_JOB_SIGNAL_PROPAGATION to have the control manager takes care of this but nothing happened... Can someone advise a solution for this use case/issue ?

Connectez-vous pour laisser un commentaire.