How to downgrade Intel Cluster Toolkit Compiler Ed. for Linux?

How to downgrade Intel Cluster Toolkit Compiler Ed. for Linux?

We work at University of Vigo in Spain and we have an SGI machine, an Altix 450, with a SUSE 10 installed. We've got the "Intel Cluster Toolkit Compiler Edition for Linux" with these versions of the compilers:

intel_cc_10.1.008;
intel_mpi_3.1
intel_mkl_10.0.11
intel_idb_10.1.008
intel_fc_10.1.008

But we've to install/compile a software (Gaussian) that doesn't support this wersion of the compilers.

We need this other version of the compilers:

Intel Version 7.1, Build 200312011_fc_pc_7.1.037;
Intel 7.1, Build 200312011_cc_pc_7.1.034;
Intel MKL 6.0.

So we need to know how can we adquire this versions usisng our product serial number.

Tranks

4 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Quoting - admonuvigoes

We work at University of Vigo in Spain and we have an SGI machine, an Altix 450, with a SUSE 10 installed. We've got the "Intel Cluster Toolkit Compiler Edition for Linux" with these versions of the compilers:

intel_cc_10.1.008;
intel_mpi_3.1
intel_mkl_10.0.11
intel_idb_10.1.008
intel_fc_10.1.008

But we've to install/compile a software (Gaussian) that doesn't support this wersion of the compilers.

We need this other version of the compilers:

Intel Version 7.1, Build 200312011_fc_pc_7.1.037;
Intel 7.1, Build 200312011_cc_pc_7.1.034;
Intel MKL 6.0.

So we need to know how can we adquire this versions usisng our product serial number.

Tranks

Have you considered that such old software hasn't been tested on a recent OS, and may be incompatible?

Have you registered your Cluster Toolkit at https://registrationcenter.intel.com and checked what older versions may be available to download?

Do you have a reason for avoiding a currently maintained version of Gaussian?

Quoting - tim18

Have you considered that such old software hasn't been tested on a recent OS, and may be incompatible?

Have you registered your Cluster Toolkit at https://registrationcenter.intel.com and checked what older versions may be available to download?

Do you have a reason for avoiding a currently maintained version of Gaussian?

Our OS version is compatible with the software version we've checked this with software tech support.

We've registered our Cluster Toolkit but there isn't 7.1 version available to download at https://registrationcenter.intel.com (the oldest version available to download it's 8.0).

And to adquire the latest version of Gaussian that will be compatible with the actually compilers version we've to pay around 4000$. Obviously that's the reason why we are trying to adquire older compilers and not the newest software.

So we still can't work, how can we adquire that compilers version? Please help us.

Thankyou

If your Cluster Toolkit license doesn't give you access to download individual compilers on registrationcenter, you might make a support request on premier.intel.com, explaining your needs. There was no Cluster Toolkit back then. You still run the risk that such an old compiler may pose difficulties on a current system. ifort 7.1 is library incompatible with more recent versions of ifort. If Gaussian has libraries built with ifort 7.1, I could understand your request; otherwise, I would think the risks of building an old version of Guassian with a current compiler might be less than the risk of using an unsupported compiler on a current system.

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui