PXE Compatibility

PXE Compatibility

We have a HP DC-7700 workstation as our test platform to test our AMT development on. I have now found that this same station can not boot the older manageability platform from Intel(PXE), properly anymore. When I use the old Intel PDK for PXE (build 082), and I select to boot DOSUNDI the DOS session will halt with "COMMAND.COM is missing" even before the CONFIG.SYS is loaded. Is this an HP implementation problem, or might it be as a result of the newer PXE implemented on this station (which is build 085). The last release of the PXE PDK that Intel released was build 082.

Who will be responsible for the fix? 1) Intel for the PXE PDK not working on this station, or 2) HP because their workstation can not boot with the PXE PDK build 082?

I have made sure that my Intel PXE PDK server work by testing some of our pre AMT workstations with PXE against it, and they could perform the API test and DOSUNDI boot. ;-)

Johan van den Berg

Senior Software Developer / Systems Architect

Columbus SA (Pty) Ltd

+27 (0) 12 657 5377 - office

+27 (0) 12 657 0454 - fax

+27 (0) 84 526 2188 - mobile

5 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Hello,
Could you check on the following items?

What HP BIOS is loaded up on your DC7700?
What version of the Intel Boot Agent is integrated into the HP BIOS?
How do you have iAMT provisioned?
Do you only have trouble PXE booting using the old PDK as your boot server?
Have you tried any other PXE servers like a Microsoft RIS, or Linux Quickstart server?

The error that you're receiving halt with "COMMAND.COM is missing" even before the CONFIG.SYS is loaded. sounds like it could be a problem with your PXE boot image...

Thx

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Thanks for the reply.

The system BIOS version is: 786E1 v01.05
The Intel boot agent version is: GE v1.2.40
PXE version is: v2.1 build 085. (This is a bit strange for me because our
company also develops PXE bootroms (meaning we got the PXE SDK from Intel for
that) and the latest PXE SDK that was available from Intel was build 082,
released more than +-5 years ago)

I made sure that my PXE server is healthy by booting at least 10 other stations
(different brands like Compaq, Mecer, ABIT, etc. and also with different PXE
bootroms from Intel and some of our own) against it, with exactly the same boot
image ("DOSUNDI.1", which was generated ages ago by a script inside
the PXE PDK). We never update this server as we use it solely to test that our
PXE bootroms are fully functional as tested against the Intel PXE PDK.

I know I shouldn't guess, but (if I may)... I actually suspect that DOSUNDI.0
is creating it's ram drive at a bad location in memory (because the BIOS might
be reporting the amount of RAM wrongly, or it does not have all the needed
functions implemented), or that DOSUNDI.0 is not protecting its ram drive
properly (It does this by reporting less ram to system once it has created the ram
drive). I don't know how to confirm this, it just seems like a probable cause,
and surely not the only one at that.

Thanks.
Johan.

Some more testing and help from our Intel representative (Vadim Sukhomlinov)...

The problem seems to be related to the system not having a physical floppy drive, and then booting a Win9X DOS image with the PXE PDK utilities.

I hopewe will see an update in the PXE PDK to fix this then?

BTW, The 1.06 firmware is available on the HP website. I don't think this version has very many fixes in it - but just thought I'd tell you in case you didn't know.

--GTH

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui