MPEG-4 decoder can't decode mpeg stream from my DSP board !

MPEG-4 decoder can't decode mpeg stream from my DSP board !

It has some problems with B-VOP's. After decoding a few macroblocks itstops decoding with an error "Error when decode B-VOP macroblock". Macroblock type (code) is 0.

6 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Dear Customer,
Have you submitted this issue with detailsto Intel Premier Support at https://premier.intel.com where our support staff will look into this issue?

Thanks,
Ying S
Intel IPP Support

Not yet ...

I'v attached an examplempeg-4 stream, maybe there is some simple answer, why it doesn't work... ( Extension shoud be changed to *.cmp )

Hi,

thank you for the data, we will look on it. Please, submit this issue to the tech support as well.

Regards,
Vladimir

Hi,

we discovered that

The first error is in the first B-VOP in bits for macroblock number 3 (starting with 0). The byte sequence for first B-VOP (offset in file - 0x1704) is

00 00 01 B6 90 00 B8 54 8F 4D 07 A1 ...

Header info occupies bytes "00 00 01 B6 90 00 B8 54" and first 3 bits of "8F"

Info for macroblock 3 is started from bit 1 in byte "A1". Bits 1-2 indicates modb and next 1-4 bits indicates mb_type and must be "1", "01", "001", "0001", but next four bits are "0000".

Byte - A1

Bits - 10100001

BitPos - 0......7

modb - 01, mb_type - 0000 (illegal bit sequence)

Regards,
Vladimir

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui