Fortran 9.1.052 on Red Hat Enterprise Linux Server release 6.3

Fortran 9.1.052 on Red Hat Enterprise Linux Server release 6.3

Hi,

I am have problems installing Fortran 9.1.052 on Red Hat Enterprise Linux Server release 6.3 machine. Error message is:

IPO link: can not find -lrt
ifort: error: problem during multi-file optimization compilation (code 1)
/cadappl/ato/marc/2008r1/marc2008r1/tools/run_marc: link failed for /home/support/delphi_epad.o

First question: Is 9.1.052 supported on RHES 6.3?

Second question: If 1 is true, what is missing/wrong? Developper tools are installed.

Regards,

john

 

4 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

No, ifort 9.1 isn't supported on RHEL 6.x. I think 12.0 was the first version to be tested fully for support of RHEL 6.x. 6.3 may be too new to have been tested fully on 6.3 prior to release even of the current version, although I would hope that it doesn't present any new problems for the compiler versions which are designated as supporting RHEL 6.1 or 6.2.
According to your result, I wouldn't trust the IPO option (invoked e.g. by -fast) with the combination you are using. If you are using vendor supported software where IPO objects are supplied, you should consult that vendor's support team.
It would probably be of interest to know whether you are using the x86_64 flavor of linux and the Intel64 flavor of ifort.

Hi Tim,

Thanks for your respons. I'll check with MSC Software, they are my vendor, how to solve, it it can be solved at all.

Regards,
John

Hi John
I assume, you can solve this problem very quickly by not linking statically ( and e.g. don't use -fast since this implies -static). Starting with RHEL 6.0, Redhat no longer ships the static version of many libraries including libm and librt. This vey likely causes your linker error.

Heinz

Connectez-vous pour laisser un commentaire.