Compatibility of Intel Compiler to glibc

Compatibility of Intel Compiler to glibc

Hello,

I'm using Intel Compiler 11.1/064 to compile my application.

Is there a limitation of glibc version that I can use ?

Currently I'm using glibc2.9 compiles with crosstool-ng (also used to create gcc 4.3.2)

Thanks,

Zvika

5 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

The release notes should tell which glibc versions were fully tested with that compiler (sometimes implicitly, according to linux distro version). Outside the quoted range, it may work, but you're on your own. Usually, other issues become more important, such as gcc version, where I believe 11.1 will go up to gcc 4.5 (perhaps further, if you don't use C++).

Hi,
You can refer to this article (Page 17-18) http://software.intel.com/sites/products/collateral/hpc/compilers/intel_... , which provides an table for compatible Glibc, Kernel & g++ versions supported for range of the compilers.

Regards,
Sukruth H V

Hello,

Thank you for the link.
According to the link, kernel 3.x is not supported at all.
Will this change soon ?

Thanks,
Zvika

Hi Zvika,
I would let you know about this.

Regards,
Sukruth H V

Connectez-vous pour laisser un commentaire.