debugging mode problem

debugging mode problem

I'm working in IVF 11.1.065 under Windows XP.

My code structure is shown below;

program mainimplicit none
integer ...
real...
open(100,file='input.dat',action='read',status='old')
read(11,*) problem_name
read(11,*)
read(11,*) Var1..

call ...
..

end program main
And the 'input.dat' is;
PROBLEM_NAME

VAR1
VAR1_VALUE
VAR2
VAL2_VALUE...

When I try to debug with other breakpoint, it always breaks at read(11,*) problem_name
If I do something wrong, please let me know.

6 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.
Portrait de Les Neilson

Assuming you wish to read the contents of the file
change read(11
to read(100

Les

Citation :

Les Neilson a écrit :

Assuming you wish to read the contents of the file
change read(11
to read(100

Les

Sorry, it's my typo.
All are set to same value as

read(11,file=...)
read(11,*)

Portrait de Les Neilson

The input file needs to be in the same directory as the exe you are running.
Les

Portrait de Steve Lionel (Intel)

What Les says is true if you are running from the command line, but if you are running from Visual Studio, the default file location is the project location, not the subfolder where the EXE is.

Steve
Portrait de Les Neilson
Best Reply

Ah yes, if you are debugging from Visual Studio look at the project properties :
Configuration properties -> Debugging -> Working directory
that needs to point to where your data file resides.
By default (i.e. if blank) it is the directory where your project file is found.
Les

Connectez-vous pour laisser un commentaire.