Warning are not displayed in the console

Warning are not displayed in the console

Portrait de Heinz Michael L.

Hello,

I'm using the latest fortran compiler from Intel. I use the console, not visual studio. And I run it out of the winteracter ide.

Everything works, but the protocoll from compiling, which is sent to the console, shows no warnings. I can only see the warnings, when i redirect the output to a file. And specifying /Qdiag-error:warn,remark works, this displays me warnings and remarks as errors, but this stops compiling.

Is there an other way to get warnings and remarks displayed? What I'm doing wrong?

Thank you and best regards,

Heinz

 

 

6 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.
Portrait de bmchenry

Do you have a 'Console' window in the Winteracter Development Environment?
Also from the project menu can you view Errors/Warnings by Menu or F6.
If only Errors, you might check the INTEL Fortran option to display warnings set in the 'Switches'? /warn:all ?
I would send your tech support question to Winteracter
help@winteracter.com
They are very prompt in their responses (except now since it is 1030 PM or so their time :-)
so check their tech support page http://www.winteracter.com/suppwint.htm

Portrait de Heinz Michael L.

Yes, I have a console-window in the ide. And I tried /warn:all , no effect. Warnings are not displayed in the console-window. I get only the message, that warnings did occour, not more.

Portrait de mecej4

I am not familiar with the IDE that you use, but note that if it displays a simulated command window, but fails to redirect both STDOUT and STDERR streams from the compiler into that simulated window, the simulated window may fail to show one of the output streams.

Portrait de Winteracter

WiDE redirects both STDOUT and STDERR, so that's not the issue. WiDE parses the output from the compiler to determine how warnings and/or errors have been reported. It then displays the compiler's output in its console, depending on the "Reporting Level" as selected via the Settings|Error/Warning Reporting menu option. This can be set to "Errors only", "Errors and warnings" or "Full". It sounds like the original poster has "Errors only" selected.

Note : This isn't really the right place to submit Winteracter related support issues. Support requests regarding Winteracter should be submitted to ISS as per the instructions on our technical support page at http://www.winteracter.com/suppwint.htm#subm .

Portrait de Heinz Michael L.

@ Winteracter:

Thank you for your posting. My mistake, I didnt realize, that there is Dialog for setting the reporting level. I had the default "Errors only". Sorry for posting here and not to the Winteracter support. I thought it would be a compiler problem.... never mind .... ;-)

Thank you all for your help,
best regards,
Heinz

Connectez-vous pour laisser un commentaire.