OMP: Warning #90:..

OMP: Warning #90:..

Hi,

Just downloaded and installed w_mkl_11.0.1.119.exe

After running the first test I get the - bundle of- :

OMP: Warning #90: ittnotify: Lookup of “__itt_<function>”
function in <installdir><redistlibpath>\pdbx.dll library failed.

Looking at the documentation, I see I have to ignore it. My question is how can I get rid of it?

(vs2010, win7 64bit ).

Thank you very much in advance,

P-

53 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

at the first glance the work around of this problem you can see following this link: http://software.intel.com/en-us/forums/topic/285302

Have you tried the environment variable KMP_WARNINGS=off ?  It should make the OpenMP RTL to not issue any warnings.

Regards,
Andrey

Gennady, Andrey,

Thank you very much for your help

P-

Andrey,

What do you mean by "environment variable KMP_WARNINGS=off" ?

I looked in my environment variables and there is no environment variable KMP_WARNINGS (win7, 64bit).

Is this a setting in vs2010 ? Should I do it programmatically ( I really hope no)

(the parallel debug trick to off failed to silense the omp warnings).

Thank you in advance,

P-

You need to add environment variable KMP_WARNINGS youself. Alternatively call kmp_set_defaults("KMP_WARNINGS=0") if using Fortran

Hi Andrew,

Thank you for coming back to me .

Andrew,

It does not seem to work ! tried woith value off and with value 0. (restarted th vs2010).

Any other suggestion ?

Also, using c++.

I am sorry, there is a problem in the OpenMP RTL with this warning (it is issued before we turn the warnings off, so we cannot disable it at the moment).  We will work on the problem and hopefully solve it in the next release of the library.

- Andrey

Thank you Andrey,

P-

Petros,

Could you please check what OpenMP library version you run your test with?

Set environment variable KMP_VERSION=1 and run your test. And see the output.

Thank you.

Hi Olga,

I am really only using OpenMP through mkl. My (c++) program does not use openmp.

I am using intel c++ compiler 12.1 for win (7 64bit) with 64bit builds.

Will get back to you,

Thank you very much for your effort to help.

P-

Hi Olga,

I inserted the env. variable you asked me to. Also inserted the KMP_WARNINGS=0 and disabled openMP support from my compiler (c++ intel 12.1 with c++0x enabled).

Still getting the warnings though..

I don't know if this helps but when I put the warnings as "off" (instead of off) I got the following additional message :

OMP: Hint: Use "0", "FALSE". ".F.", "off", "no" as false values, "1", "TRUE", ".T.", "on", "yes" as true values.
OMP: Warning #20: KMP_WARNINGS=""off"": Wrong value, boolean expected.
OMP: Hint: Use "0", "FALSE". ".F.", "off", "no" as false values, "1", "TRUE", ".T.", "on", "yes" as true values.
Intel(R) OMP Copyright (C) 1997-2011, Intel Corporation. All Rights Reserved.
Intel(R) OMP version: 5.0.20110606
Intel(R) OMP library type: performance
Intel(R) OMP link type: dynamic
Intel(R) OMP build time: 2011-06-07 02:07:15 UTC
Intel(R) OMP build compiler: Intel C++ Compiler 12.0
Intel(R) OMP alternative compiler support: yes
Intel(R) OMP API version: 3.0 (200805)
Intel(R) OMP tracefile support: no
Intel(R) OMP dynamic error checking: no
Intel(R) OMP helper thread support: yes
Intel(R) OMP thread affinity support: not used
Intel(R) OMP debugger support version: 1.1
Intel(R) OMP Intel(R) RML support: not using

Also, tried these as both user and system environment variables - just in case..

Thank you for your help,

Petros

Hi Petros, Let me answer these questions:

>>Is this a setting in vs2010 ?

No. Visual Studios do not set any OpenMP environment variables.

>>Should I do it programmatically ( I really hope no)

You can do it programmatically, if it really needs to be done, and here is a small example in a C language:
...
int iRetCode = _tputenv( _T("KMP_WARNINGS=off") );
if( iRetCode == 0 )
_tprintf( _T("KMP_WARNINGS=%s\n"), _tgetenv( _T("KMP_WARNINGS") ) );
else
_tprintf( _T("Error: Failed to Set Environment Variable KMP_WARNINGS\n") );
...

Hi Petros,

It looks like you are using a quite old compiler and old OpenMP library. It is dated

Citation :

Intel(R) OMP version: 5.0.20110606

The problem with Warning #90 was fixed in the OpenMP library version 20111108. It is available in the Compiler 12.1 Update 8 (Intel(R) C++ Composer XE 2011 Update 8).

Regarding the Warning #20 and hints I would say this is expected behavior because you inserted extra quotes in the variable value.

The correct syntax is

KMP_WARNINGS=off

KMP_WARNINGS=0

etc. ... without quotes.

Hope it helps you.

Thank you.

 

Olga,

But I amnotusing openMP with my compiler in my c++ program - the flag is unchecked. I thought these messages are coming from the mkl openMP library. This is the command line from vs2010 :

/Zi /nologo /W3 /MP /Od /D "WIN32" /D "_DEBUG" /D "_CONSOLE" /D "_SCL_SECURE_NO_WARNINGS" /D "_CRT_SECURE_NO_WARNINGS" /D "BOOST_UBLAS_SHALLOW_ARRAY_ADAPTOR" /D "_UNICODE" /D "UNICODE" /EHsc /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Qstd=c++0x /Fp"x64\Debug\test_libRandom.pch" /Fa"x64\Debug\" /Fo"x64\Debug\" /Fd"x64\Debug\vc100.pdb"

Sergey,

Thank you, had figured out meanwhile.

Citation :

Petros Mamales a écrit :

I amnotusing openMP with my compiler in my c++ program - the flag is unchecked. I thought these messages are coming from the mkl openMP library.

Yes, the MKL uses the OpenMP library. If you installed the MKL as standalone but not as a part of the Composer then the MKL should have installed libraries it depends on (like OpenMP library). MKL 11.0 installation package should contain the right version of the OpenMP library that has the fix for the warnings. But it looks like when your test calls the MKL it finds some old version of the OpenMP library (that was most likely installed with the old version of the compiler).

All this is very confusing. Especially in light of the suggestion I was given in the forum, at an earlier question, to not mix the mkl omp library and the c++ provided one.

I installed mkl 11 as part of my mkl support's update ( my composer support has expired ). I really don't understand what I have to do. Is there a way to reinstall mkl and bypass the libraries that it finds from the composer installation ?

It is really annoying, what is happenning, especially when you try to debug.

>>...It is really annoying, what is happenning, especially when you try to debug.

Petros,

When you're debugging in a Visual Studio please take a look at Output Window and find a section with a list of loaded DLLs ( they are always with full paths ). That verification could help you to understand what Intel DLLs are actually loaded and used by your application. Let me know if you need a small example on how it looks like, or post everything from Output Window ( when debugging! ) for our review.

OLga,

(typical example)

ittnotify: Lookup of "__itt_stack_callee_leave" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.

And now that I know it, what do I do with ir ?

ps: The onlky dll loaded should be the one from mkl . If, as you say, this one is properly fixed, since I am using the latest and greatest one, then I should not see the messages.

Alas, no, the installation opted for not installing the newest dll because it found another one (older !! and therefore not fixed!!) , which chose to mantain so that other parallel studio utilities do not break down. Understood as conceivable.

Eh, well maybe the iwhole distribution model has some issues ?

OLga,

(typical example)

ittnotify: Lookup of "__itt_stack_callee_leave" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.

And now that I know it, what do I do with ir ?

ps: The onlky dll loaded should be the one from mkl . If, as you say, this one is properly fixed, since I am using the latest and greatest one, then I should not see the messages.

Alas, no, the installation opted for not installing the newest dll because it found another one (older !! and therefore not fixed!!) , which chose to mantain so that other parallel studio utilities do not break down. Understood as conceivable.

There's got to be a (much) better way to distribute updates..

>>ittnotify: Lookup of "__itt_stack_callee_leave" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer
>>SP1\redist\intel64\compiler\pdbx.dll" library failed.

- These problems could be related to Intel Threading Building Blocks ( TBB ) library ( it has to be confirmed... )

- The TBB dynamic library, Tbb.dll, is possibly used by Pdbx.dll

- Ittnotify message Lookup of "__itt_stack_callee_leave" function could be displayed from Tbb.dll or from Pdbx.dll and that is why some additional information is needed. That is, a complete output from VS Output Window of your application.

Sergey,

I am using tbb in my code. It is the tbb41_20120718oss distribution - but not in this project, although the libs are avail to link as part of more general property sheets and vc++ directories settings.

This is what is found in the Output window :

'test_libRandom.exe': Loaded 'C:\_petros\_otc\src\otc\x64\Debug\test_libRandom.exe', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Windows\System32\ntdll.dll', Cannot find or open the PDB file
'test_libRandom.exe': Loaded 'C:\Windows\System32\kernel32.dll', Cannot find or open the PDB file
'test_libRandom.exe': Loaded 'C:\Windows\System32\KernelBase.dll', Cannot find or open the PDB file
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_rt.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Windows\System32\msvcrt.dll', Cannot find or open the PDB file
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\tbb\vc10\tbb_preview_debug.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Windows\System32\msvcp100d.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Windows\System32\msvcr100d.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\libmmdd.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll', Cannot find or open the PDB file
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\tbb\vc10\tbbmalloc_debug.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_intel_thread.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_core.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\libiomp5md.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_vml_mc3.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_mc3.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\libimalloc.dll', Binary was not built with debug information.
'test_libRandom.exe': Unloaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\libimalloc.dll'
The thread 'Win64 Thread' (0x1538) has exited with code 1 (0x1).
The thread 'Win64 Thread' (0x154c) has exited with code 1 (0x1).
The thread 'Win64 Thread' (0x9e4) has exited with code 1 (0x1).
The thread 'Win64 Thread' (0x13c4) has exited with code 1 (0x1).
The program '[9364] test_libRandom.exe: Native' has exited with code 1 (0x1).

And - in case this helps- this is the output of the code :

OMP: Warning #90: ittnotify: Lookup of "__itt_heap_function_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_function_createW" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_allocate_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_allocate_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_free_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_free_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_reallocate_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_reallocate_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_internal_access_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_internal_access_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_createW" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_createW" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_destroy" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_inc" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_inc_delta" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_caller_create" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_caller_destroy" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_callee_enter" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_callee_leave" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
Intel(R) OMP Copyright (C) 1997-2011, Intel Corporation. All Rights Reserved.
Intel(R) OMP version: 5.0.20110606

Thank you and Olga for your help,

P-

ps: apologies for last comment - I have been very frustrated about some of these things, but obviously everyone here has tried and has been very helpful.

Thanks, Petros and I don't see any problems and all Intel DLLs are loaded from:

'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\..."

[ Olga's statement ]

>>>>...MKL 11.0 installation package should contain the right version of the OpenMP library that has the fix for the warnings...

[ Petro's version ]
...
Intel(R) OMP version: 5.0.20110606

Olga, this is what Petros has. Does Intel(R) OMP version: 5.0.20110606 have that fix?

Petros,

Since you installed MKL 11.0 I guess you supposed to use it with your test, right?

But from the Output  you gave it is clear that all libraries (including MKL and OpenMP) are loaded from Composer 2011 SP1.

If you correctly installed MKL 11.0 it would located in the directory like C:\Program Files(x86)\Intel\ComposerXE-2013\mkl\. Please, see Installation Guide for MKL 11.0 for installation tree - http://software.intel.com/en-us/articles/intel-mkl-110-install-guide

So, your Visual Studio project has incorrect path to libraries.

To fix it and use correct libraries you can add correct path to your project.

First, check that you really have MKL 11.0 installed in the path I mentioned above (with the folder name ComposerXE-2013).

Open Project Property Pages -> Configuration Properties -> VC++ Directories.

Add the path to MKL libraries (C:\Program Files (x86)\Intel\Composer XE 2013\mkl\lib\<arch>) to Library Directories.

Add the path to other shared libraries - including OpenMP (C:\Program Files (x86)\Intel\Composer XE 2013\compiler\lib\<arch>) to Library Directories.

<arch> - architecture (ia32 or intel64).

Save properties, run your test and check output for loaded library path.

Hope it can help.

Citation :

Sergey Kostrov a écrit :

Olga, this is what Petros has. Does Intel(R) OMP version: 5.0.20110606 have that fix?

No, 20110606 does not have the fix.

The problem is that all libraries including MKL and OpenMP (libiomp5md.dll) are loaded from Composer XE 2011 whereas the MKL 11.0 istallation would have directory structure from Composer XE 2013. It means something is wrong with MKL 11.0 installation...

I attached the picture with Properties dialog...just in case.

Fichiers joints: 

Fichier attachéTaille
Télécharger prop.jpg121.33 Ko

>>...Composer XE 2013...

I'm not sure that Petros has it installed and I see that Petros has:

- ...I am using intel c++ compiler 12.1 for win (7 64bit) with 64bit builds...

and

- ...Just downloaded and installed w_mkl_11.0.1.119.exe

Petros, could you check a version of libmmd.dll using Windows Explorer ( find the libmmd.dll, select it, look at properties, look at Version property page ). This is what I have:

- for Intel C++ compiler version 12 - File Version = 12.0.12.2
- for Intel C++ compiler version 13 - File Version = 12.0.12.2

File versions are the same ( it is strange... ) but sizes are different.

>>>>Olga, this is what Petros has. Does Intel(R) OMP version: 5.0.20110606 have that fix?
>>
>>No, 20110606 does not have the fix.

Thank you, Olga.

>>The problem is that all libraries including MKL and OpenMP (libiomp5md.dll) are loaded from Composer XE 2011 whereas
>>the MKL 11.0 istallation would have directory structure from Composer XE 2013. It means something is wrong with MKL 11.0
>>installation...

I agree with that.

Petros, I understand that the warning message is displayed every timne when you're debugging. But, this is just warning and could you simply ignore it? As soon as you have Composer XE 2013 it won't be displayed.

Please, just ignore the warning message because I don't think something else could be done.

Best regards,
Sergey

Olga and ergey,

First of all thank you for your help.

After these emails I am a bir confused..

Olga,

in my property sheets I use the env variable mklroot to point to the include and lib/bin directories of mkl.

hecking on a command prompt for the environment variable I see :

C:\Users\petros>echo %mklroot%
C:\Program Files (x86)\Intel\Composer XE 2011 SP1\mkl
So, not Composer XE 2013 etc.

So I changed the mklroot environment variable to point where you are saying.

And now the env var prints fine. . Restarted the vs2010. Rebuilt everything. etting the same messages as beore - oblivious to thechange of the

env var. Is it possible that this collides with an mkl defined mklroot ?

And yes, I am using - or at least I hoPE I am, the newest mkl version and during installation followed all the default settings.

I will have to look more into this in daylight ( it is 2:45 in the morning here ;-)) )

Sergey,

If I understand you correctly, even if I correct what I am very likely doing wrong, I will still have the same problem ?

And, guys, you have no idea how long it takes for the debugger to come alive..

And I have an i7 with 18GB of memory.. It is not a nuissance, it is a real thing..

Thank you for your help,

P-

>>...you have no idea how long it takes for the debugger to come alive..
>>
>>And I have an i7 with 18GB of memory.

Please try to increase size of the Virtual Memory on your computer ( in 2 or 3 times ).

Update:

By openning an mkl file from vs (using the environment variable) and checking the path it now points to the new mkl (XE 2013 directory structure). This makes me believe that the libs are picked up from there as well. Now, if internally the dll's look for some environment variable

that is set at installation and they call the omp one from there, I don't know..

Thank you for the help,

P-

Hi Petros,

>>...By openning an mkl file from vs (using the environment variable) and checking the path...

Could you give an exact name of the DLL you've selected?

Hi Sergey,

mkl_rt.lib

Citation :

Petros Mamales a écrit :

Update:

By openning an mkl file from vs (using the environment variable) and checking the path it now points to the new mkl (XE 2013 directory structure). This makes me believe that the libs are picked up from there as well. Now, if internally the dll's look for some environment variable

that is set at installation and they call the omp one from there, I don't know..

Thank you for the help,

P-

So, you mean you are sure all dlls are loaded from the correct place (Composer XE 2013 directory tree), right?

And what's the result? You still see Warning #90 from libiomp?

Check the version of the OpenMP library again by setting environment variable KMP_VERSION=1.

Hi Olga,

I still see warning #90 (MKL_VERSION has been 1) and the message references the old location,

For example:

OMP: Warning #90: ittnotify: Lookup of "__itt_heap_function_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.

Citation :

Petros Mamales a écrit :

Hi Olga,

(MKL_VERSION has been 1) 

Note, the env var name should be KMP_VERSION=1. Set it in your VS project and copy all messages from Output Window here (like you did above).

We'll check the pathes to loaded libraries.

Citation :

Petros Mamales a écrit :

Hi Olga,

(MKL_VERSION has been 1) 

Note, the env var name should be KMP_VERSION=1. Set it in your VS project and copy all messages from Output Window here (like you did above).

We'll check the pathes to loaded libraries.

I don't understand what you mean when you say "Set it in your VS project ".

Where do you do this ? I did it in ControlPanel->System->environment variables

OK , I get it. Properties->Configuration->Debugging etc.

Did it and rebuilt. Same results, as far as I can tell :

OMP: Warning #90: ittnotify: Lookup of "__itt_heap_function_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_function_createW" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_allocate_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_allocate_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_free_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_free_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_reallocate_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_reallocate_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_internal_access_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_internal_access_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_createW" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_begin" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_frame_end" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_createW" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_destroy" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_inc" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_counter_inc_delta" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_caller_create" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_caller_destroy" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_callee_enter" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
OMP: Warning #90: ittnotify: Lookup of "__itt_stack_callee_leave" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
Intel(R) OMP Copyright (C) 1997-2011, Intel Corporation. All Rights Reserved.
Intel(R) OMP version: 5.0.20110606
Intel(R) OMP library type: performance
Intel(R) OMP link type: dynamic
Intel(R) OMP build time: 2011-06-07 02:07:15 UTC
Intel(R) OMP build compiler: Intel C++ Compiler 12.0
Intel(R) OMP alternative compiler support: yes
Intel(R) OMP API version: 3.0 (200805)
Intel(R) OMP tracefile support: no
Intel(R) OMP dynamic error checking: no
Intel(R) OMP helper thread support: yes
Intel(R) OMP thread affinity support: not used
Intel(R) OMP debugger support version: 1.1
Intel(R) OMP Intel(R) RML support: not using

Hi Petros, I'd like to make a couple of notes.

1. I have a primary computer system with Windows 7 64-bit OS and Intel C++ Parallel Studio XE 2013 ( Initial Release without any updates / ALL components installed ). I searched the drive C and I couldn't find pdbx.dll. It means, that the latest version of MKL doesn't use it. I can't confirm it for 100% but I see the pdbx.dll simply doesn't exists on my 64-bit OS.

2. I have a secondary computer system with Windows XP 32-bit OS and Intel C++ Parallel Studio XE 2011 ( Update 9 / MKL is Not installed ). I searched the drive C and I found pdbx.dll. It means, that pdbx.dll is a 32-bit DLL but I don't know if older versions of MKL use it.

3. Regarding the following message:
...
OMP: Warning #90: ittnotify: Lookup of "__itt_heap_function_createA" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.
...
I see that some module tries to load a pdbx.dll and it can't find __itt_heap_function_createA function. Why? I don't know. My questions are as follows:

- Do you have pdbx.dll on your 64-bit system?
and
- If Yes, Is pdbx.dll a 32-bit or 64-bit? ( You need to use MS Depends utility for that verification )

Please take a look at a couple of screenshots in my next posts.

[ 32-bit Pdbx.dll on 32-bit WIndows XP OS ]


Note: MS Depends utility used

Fichiers joints: 

Fichier attachéTaille
Télécharger pdbx.dll.32biton32bitos.jpg81.45 Ko

[ 32-bit Mkl_rt.dll on 64-bit WIndows 7 OS ]


Note: MS Depends utility used

Fichiers joints: 

Fichier attachéTaille
Télécharger mkl-rt.dll.32biton64bitos.jpg85.61 Ko

[ 64-bit Mkl_rt.dll on 64-bit WIndows 7 OS ]


Note: MS Depends utility used

Fichiers joints: 

Fichier attachéTaille
Télécharger mkl-rt.dll.64biton64bitos.jpg80.01 Ko

Now, here is a question: What am I going to prove? It is possible that you've accidentally mixed DLLs for different platforms, or some DLLs missing.

Invalid cases:

[ Case 1 ] A 64-bit application tries to use a 32-bit DLL - This is not possible

[ Case 2 ] A 32-bit application tries to use a 64-bit DLL - This is not possible

Perfect cases:

[ Case 3 ] A 64-bit application tries to use a 64-bit DLL - Should work

[ Case 4 ] A 32-bit application tries to use a 32-bit DLL - Should work

Petros,

What are VC++ Directories for your project now? (Properties->Configuration properties->VC++ directories)

And I guess you didn't copy all the Output. I'd like to see messages like what you displayed above -

'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_rt.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\tbb\vc10\tbb_preview_debug.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Windows\System32\msvcp100d.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Windows\System32\msvcr100d.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\libmmdd.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll', Cannot find or open the PDB file
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\tbb\vc10\tbbmalloc_debug.dll', Symbols loaded.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_intel_thread.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_core.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\libiomp5md.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_vml_mc3.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\mkl_mc3.dll', Binary was not built with debug information.
'test_libRandom.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\libimalloc.dll', Binary was not built with debug information.
'test_libRandom.exe': Unloaded 'C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl\libimalloc.dll'

 As I understand the problem is that the environment is wrong and you still use the old MKL and other libraries.

All what you need is to put the correct path to libraries to your project properties.

OR you can find the correct libiomp5md.dll (its location is something like C:\Program Files (x86)\Intel\Composer XE 2013\redist\intel64\compiler\libiomp5md.dll) and just copy it to your executable location (where your test *.exe file is).

New libiomp5md.dll should resolve the problem with the Warning #90.

Citation :

Sergey Kostrov a écrit :

1. I have a primary computer system with Windows 7 64-bit OS and Intel C++ Parallel Studio XE 2013 ( Initial Release without any updates / ALL components installed ). I searched the drive C and I couldn't find pdbx.dll. It means, that the latest version of MKL doesn't use it. I can't confirm it for 100% but I see the pdbx.dll simply doesn't exists on my 64-bit OS.

2. I have a secondary computer system with Windows XP 32-bit OS and Intel C++ Parallel Studio XE 2011 ( Update 9 / MKL is Not installed ). I searched the drive C and I found pdbx.dll. It means, that pdbx.dll is a 32-bit DLL but I don't know if older versions of MKL use it.

PDBX.dll is related to the Intel(R) Parallel Debugger Extension. So, it exists in the system if you installed it. The Composer XE 2013 does not contain Parallel Debugger Extension that's why you couldn't find pdbx.dll on the system with Parallel Studio XE 2013.

Note that the MKL does not use this dll directly but the OpenMP does.

In the beginning of this topic Gennady Fedorov gave the link to the other post describing the similar problem with warnings. One way how to avoid the warning is also described there - to turn off parallel debugging, that is remove /debug:parallel from the project command line. Then pdbx.dll wouldn't be loaded at all.

Olga,

The VC++ directories are :

Executable Directories:

$(MKLROOT)\bin\intel64
$(TBBROOT)\bin\intel64\vc10
$(TBBROOT)\bin\intel64\irml_c
$(BOOSTROOT)\lib\x64
$(ICInstallDir)bin\ia32_Intel64
$(VCInstallDir)bin\x86_amd64
$(VCInstallDir)bin
$(WindowsSdkDir)bin\NETFX 4.0 Tools
$(WindowsSdkDir)bin
$(VSInstallDir)Common7\Tools\bin
$(VSInstallDir)Common7\tools
$(VSInstallDir)Common7\ide
$(ProgramFiles)\HTML Help Workshop
$(FrameworkSDKDir)\bin
$(FrameworkSDKDir)\lib\win64
$(MSBuildToolsPath32)
$(FxCopDir)
$(PATH)

Library Directories:

$(MKLROOT)\lib\intel64
$(TBBROOT)\lib\intel64\vc10
$(TBBROOT)\lib\intel64\vc10\irml_c
$(BOOSTROOT)\lib\x64
$(ICInstallDir)compiler\lib\$(IntelPlatform)
$(VCInstallDir)lib\amd64
$(VCInstallDir)atlmfc\lib\amd64
$(WindowsSdkDir)lib\x64

with :

C:\Users\petros>echo %MKLROOT%
C:\Program Files (x86)\Intel\Composer XE 2013\mkl

Sergey, I believe Olga covered what you were after ?

Thank you for the help, P-

>>... I believe Olga covered what you were after ?

Petros, regarding pdbx.dll, it actually took 18 days to explain it.

Thanks.

Sergey,

I am afraid I have gotten into this bad habit ,, ;-))

Pages

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui